Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I ran the Ubuntu installer for Windows (Wubi) and now my fn+f4 button does not work in Windows anymore. This is the button that is usually the monitor switcher (primary, secondary, mirror). This now just types the letter p after a sub-second delay while I'm booted into Windows.

Is there any way to resolve this? (without removing Ubuntu).

Here are all my function buttons

  • fn+f1 (Windows Help): This does not work. Flag+f1 works but I don't care anyway.
  • fn+f2 (Print): This still works, same as Ctrl+P
  • fn+f3 (Internet): This still works.
  • fn+f4 (Monitor): This is the one that I use most but just types the letter p after a very short delay
  • fn+f5 (Sleep): This still works.
  • fn+f6 (Lock): This does not work. But I always use Flag+L anyway so I don't care.
  • fn+f7 (Brighten Screen): This still works.
  • fn+f8 (Darken Screen): This still works.
  • fn+f9 (Play/Pause): Have not tried.
  • fn+f10 (Stop): Have not tried.
  • fn+f11 (Next Track): Have not tried.
  • fn+f12 (Previous Track): Have not tried.
share|improve this question

2 Answers 2

The reason for the letter P being typed is because Microsoft gave a recommendation to the hardware manufacturers to actually type "Win+P" if the person hits the monitor switching key. This is hardcoded in your hardware.

http://mjg59.livejournal.com/121851.html

share|improve this answer
    
Win+P does not work either. It has the same effect of typing the letter p. –  George Bailey May 11 '11 at 14:13
    
Which is why you're getting a P -- because Win+P is meaningless in Linux. That Fn key, prior to this recommendation by Microsoft, would have sent an OS call. Now it just sends a Windows-specific keyboard shortcut. If you were Greek, you might get Pi when you press that key though. –  maco May 11 '11 at 15:00
    
So are you saying that I am actually running Linux when I boot into Windows? All this is happening with Windows. Have not yet tried to boot to Ubuntu. –  George Bailey May 11 '11 at 15:03
    
OH! You're asking on a Linux site, so I assumed you meant in Linux. I'm going to change your original question to specify. –  maco May 11 '11 at 15:09

The reason why it is displaying a p is because the monitor switching function is still activated, if you're using Windows 7, just hit fn+F4 again and it will display the several display options, choose the one you need and hit Enter, this will deactivate the function and the F4 will become normal again.

share|improve this answer
    
Pressing Fn+F4 just types the letter 'p' according to the question. –  Mark Paskal Oct 23 '12 at 13:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.