Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried installing Zentyal on my ubuntu 13.10-serve using the ppa-method (as I don't want to reinstall the OS).

At first, I added deb http://archive.zentyal.org/zentyal 3.3 main extra to my sources.list and ran sudo apt-get update, followed by a sudo apt-get install zentyal.

Stripped by the installation of the dependencies, you can find the installation log here (unfortunately in German): http://pastebin.com/vLN2UWgn . The output at the end of the log is just the output from etckeeper.

As stated in the log, the post-install script of zentyal-core failed. Thus, I tried running zentyal-core.postinst in /var/lib/dpkg/info. There is some strange behaviour to be observed now.

sudo ./zentyal-core.postinst gives:

Use of uninitialized value $action in string eq at /usr/share/debconf/frontend line 27.

whereas sudo bash zentyal-core.postinst gives:

 Can't exec "zentyal-core.config": No such file or directory at /usr/share/perl/5.14/IPC/Open3.pm line 186.
 open2: exec of zentyal-core.config configure  failed at /usr/share/perl5/Debconf/ConfModule.pm line 59

In case that it matters, my default shell is fish (but not for root, that one is using bash).

After removing the post-install script, dpkg runs fine, but pointing firefox at my server just shows the default apache welcome page ("This is the default webpage ... blah blah").

Any ideas?

share|improve this question

1 Answer 1

Try using the Zentyal ISO instead of PPA. It worked for me. Can be downloaded here (3.4): http://www.zentyal.org/server/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.