Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've logged into my Ubuntu server from work via putty under Windows. Right away I noticed something weird. I could not use the ls command. Got:

-bash: /bin/ls: no such file or directory

I didn't pay much attention, I thought it was a putty thing.

Tonight I've logged from home via ssh under Ubuntu and I get the same problem on my server!

Not only that but other commands like find give me the same message.

I've also noticed that all colours are gone in the prompt.

If I echo PATH, I get :

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games

to replace lsI can use dirand it works, but that's only a temporary workaround.

Also I've tried:

ldd /bin/ls

gives me is not and dynamic executable

What could be the problem ?

EDIT

Oh and running apt-get updategives me:

W: Failed to fetch http://ftp.free.fr/mirrors/ftp.ubuntu.com/ubuntu/dists/precise-backports/universe/i18n/Translation-en Something wicked happened resolving « ftp.free.fr:http » (-5 - No address associated with hostname)

share|improve this question
    
Did you fixed it? Have you tried type ls ? –  Hastur Jun 17 at 22:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.