Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed a fresh 11.04. Then I've configured it to use Xmonad. In Xmonad I'm using Mod4+S to move through workspaces, but in new Ubuntu gnome-panel catches this shortcut earlier and shows me up with menu (same you see when pressing power button in the most right position in gnome panel).

So the subj is: How to disable Mod4+S in fresh Ubuntu 11.04?

I've tried to scan with gconf for Mod4 and Super keys but found only compiz bindings (removing doesn't help). If I will configure Mod4+S for something in 'Keyboard shortcuts' it works, but after disabling it again shows me menu.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

As my problem is caused by a hardcoded key bindings to the indicator-applet I removed that code and pushed a clean indicator-applet to my PPA. The patch is the same as this one.

PPA

share|improve this answer
add comment

Go to CompizConfig Settings Manager , then click Desktop on the right side. Click Expo (Doesn't mean to uncheck, just go inside Expo). finally, at the top there will be Expo key. You can enable or disable that as you require. There it will be like s key. By the way, if you don't have CompizConfig Settings Manager , the you can install from Software center. It's quite handy.

share|improve this answer
    
Changing this setting does not disable the Super+S shortcut. It adds a second Expo key. –  ændrük May 11 '11 at 13:19
    
This doesn't help. I'm not using Compiz, just Gnome + Xmonad. The same behavior you can see if login in 'Gnome classic' session. –  Mikhail May 11 '11 at 13:22
    
Well, this is the solution i know. It worked perfectly for me. If u don't find other way, may be you should use Compiz. –  nebula May 11 '11 at 13:25
    
I need to admit, that I've a computer with the same config (Xmonad + Gnome) but dist-upgraded to 11.04 and Mod4+S is not binded in there. –  Mikhail May 12 '11 at 5:43
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.