Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently unable to load the desktop (ubuntu 13.10, AMD64) following installing 13.10, then trying to install the latest nvidia driver (x86-64-331.38) from tty (after having to stop lightdm). The installation failed (I do not remember the exact message); when I rebooted I was unable to start the desktop. Am I correct in thinking that the video driver is what is causing this?

Here's where it gets worse: I locked the root, so I am unable to uninstall/reinstall via root shell in recovery mode. All other options on the recovery screen end up hanging after a few lines (a known bug?). I have tried adding init=/bin/sh to the linux line in the grub file; I have access to a shell here but get a warning ("can't access tty; job control turned off") and I cannot (or do not know how to) run files.

My question is: is there anything I can do to restore the video without having to wipe the computer and reinstall everything? Can I start up from cd? I'm not sure if this helps but I have an ubuntu...iso file that I appear to have access to. I am happy to provide any additional information.

Thanks for any help.

share|improve this question
    
I figured out how to unlock the root. When the shell prompt, remount the disk as rw, then unlock root. When I rebooted I was able to access the root shell. –  user247453 Feb 12 at 14:30
    
Now I have tried to reinstall the NVIDIA driver and I get all sorts of error messages: Skipping the runlevel check (the utility 'runlevel' failed to run). It ends up telling me that the gcc compiler is the wrong version; I have 4.8, and the driver .run file was compiled using 4.7. The install fails after this, saying that it cannot find the kernel. –  user247453 Feb 12 at 14:53
    
After downloading and installing the necessary (older) linux-header (I have 3.11 on saucy; NVIDIA needed 3.8.0-35), I tried again to install the NVIDIA driver via ./*.run. Though the installer said it was successful, nvidia-sim cannot find an NVIDIA driver. –  user247453 Feb 12 at 22:02
    
After trying many things to fix this problem, nvidia-smi was finally able to find the drivers after I purged the previously installed x-swat ppa. –  user247453 Feb 18 at 17:08

1 Answer 1

Yes you can. While you started booting your Ubuntu, you may see GRUB menu & in that menu choose recovery mode. If you have not seen recover mode keep pressing SHIFT key until you see GRUB Menu

After you getting into GRUB menu there is a option like " root drop to root shell " . From there you can do as a root user or you can reset root user password too.

There we have one more option like dpkg with which you can reconfigure your packages too. so I mean to say installing/removing/repairing your packages.

hope that helps.

share|improve this answer
    
My root is locked so I am unable to work in root shell mode, and the other options do not work (they hang). –  user247453 Feb 12 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.