Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried so many times to install mysql workbench and I faced many problems. The last one is in dependencies. I tried to solve that by typing:

sudo apt -get install mysql-workbench-community-6.0.9-1ubu1204-i386.deb

But unfortunately I got this error:

sudo: apt: command not found

How can I do that with Ubuntu 12.04?

share|improve this question
    
its not the proper way of installing deb file. –  Avinash Raj Feb 12 at 12:12
    
where was mysql-workbench-community-6.0.9-1ubu1204-i386.deb file? –  Avinash Raj Feb 12 at 12:12
    
can you help me please by providing me by the proper way .... because because i spent 3 days to install mysql workbench on ubunto 12.04 and i failed :( !!!! –  Akari Feb 12 at 12:14
    
in the download directory –  Akari Feb 12 at 12:15
add comment

1 Answer

up vote 13 down vote accepted

The proper command is apt-get instead of apt get.

You need to be careful when typing commands, as you can do lots of damage. For example, typing mkfs.ext3 /dev/sda instead of mkfs.ext3 /dev/sdb will destroy all data on that drive.

THe command's proper form is:

sudo apt-get install mysql-workbench

The above command fetches mysql workbench from the official Ubuntu repository. A repository is a web server containing many programs or files.

It seems like you already downloaded the .deb file associated with the mysql-workbench package, so you can just install it by cd /path/where/you/downloaded/file/ and then running command:

sudo dpkg -i mysql-workbench-community-6.0.9-1ubu1204-i386.deb

EDIT: If you have dependency problems, you should try sudo apt-get -f install

share|improve this answer
    
without space between them ? –  Akari Feb 12 at 12:11
1  
@Akari yes my dear. apt-get is a command without spaces –  kamil Feb 12 at 12:14
    
@Akari both ways mentioned in my answer should work for you. Just try them –  kamil Feb 12 at 12:15
    
I will try again thank u so much :) –  Akari Feb 12 at 12:15
    
last command will work. –  Avinash Raj Feb 12 at 12:16
show 9 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.