Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Solution 1

Hi I recently installed Ubuntu 13.10 on my laptop alongside windows. I have an Atheros AR9485 adapter. It worked well for a few weeks and now won't work anymore although it still works for the windows. I have tried out some of the solutions suggested but it still doesn't work. This so what I have so far done and the answers I get;

$ sudo modprobe -r iwlwifi
Error: missing module name.
FATAL: Error running remove command for iwlwifi

$ sudo modprobe -r iwlwifi.conf
FATAL: Module iwlwifi.conf not found.

$ cd /etc
/etc$ ls

Here I find the directory modprobe.d but modprobe does not exist so I try

$ cd modprobe.d
modprobe.d: No such file or directory

Then I go back to the /etc and try

$ cd /etc
$ cd modprobe.d
/etc/modprobe.d$ ls

I find the file iwlwifi.conf~ and try:

/etc/modprobe.d$ sudo modprobe -r iwlwifi.conf~
FATAL: Module iwlwifi.conf~ not found.

/etc/modprobe.d$ cd ~

$ sudo modprobe.d -r iwlwifi.conf~
sudo: modprobe.d: command not found

I had read a solution that was giving the steps below if I had succeeded. I tried to look for the .conf file and edited it as directed in the last part of this solution but it didn't work and I was unable to go beyond that;

Looks like this hardware has some problem with N configuration in WiFi. Please try:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Now try to reconnect, if it helps follow below steps

  1. Look into /etc/modprobe.d whether there are any file like intel-5100-iwlwifi-disable11n.conf then edit the file.

     sudo gedit /etc/modprobe.d/<filename_here>
    

    Edit the line that says

    options iwlwifi 11n_disable=1
    

    to

    options iwlwifi 11n_disable=0
    

    Save and reboot.

  2. If no file exists, create a new file

    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    

    Add a new line:

    options iwlwifi 11n_disable=1
    

    Save and reboot.

Solution 2:

When solution 1 failed, I tried solution 2 as shown here below;

lspci -nnk | grep -iA2 net
lsmod
iwconfig
rfkill list

lspci -nnk | grep -iA2 net

01:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI
Express Fast Ethernet controller [10ec:8136] (rev 05)
    Subsystem: Acer Incorporated [ALI] Device [1025:061f]
    Kernel driver in use: r8169
02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Device [105b:e047]
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader [10ec:5209] (rev 01)

lsmod

Module                  Size  Used by
nls_iso8859_1          12713  1 
parport_pc             32701  0 
ppdev                  17671  0 
bnep                   19564  2 
rfcomm                 69070  0 
bluetooth             371874  10 bnep,rfcomm
vesafb                 13828  1 
lp                     17759  0
parport                42299  3 lp,ppdev,parport_pc
hid_generic            12548  0 
usbhid                 53014  0 
hid                   101512  2 hid_generic,usbhid
usb_storage            62062  1 
rtsx_pci_sdmmc         23527  0 
ahci                   25819  2 
libahci                31898  1 ahci
rtsx_pci               45546  1 rtsx_pci_sdmmc
r8169                  67341  0
mii                    13934  1 r8169

iwconfig

eth0      no wireless extensions.
lo        no wireless extensions.

rfkill list

The last command did not give an output so I could not follow the instructions that were to come as shown below;

Deactivate the hardware encryption of the driver:

Code:

echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k

Any help either along these steps or any other solution will be appreciated.

share|improve this question
    
The actions concerning iwlwifi are for a different (Intel) chipset and will be ineffective for your Atheros. I suggest you edit your question to remove it and add the result of the following: dmesg | grep ath –  chili555 Feb 12 at 14:39

1 Answer 1

  • Download this driver compat-drivers-3.9-rc4-2-su.tar.bz2 to a folder on your machine.
  • Go to the folder and unzip the tar file using tar xf compat-dri....
  • cd into the unzipped file and issue the following commands;
./scripts/driver-select ath9k
sudo make
sudo make install
sudo make unload
  • Reboot your system.

Hopefully, it works now.

share|improve this answer

protected by Eliah Kagan Oct 26 at 16:59

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.