Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

if somebody knows an answer to Access Point question! I set up an AP with Hostapd. Works fine if AP is on wireless interface wlan0 and connection to the Internet is wired eth0. I get up/down speeds around 34Mbps. However if instead of wired eth0 I use second wireless wlan1 as a connection to the Internet, I get very low bandwidth around 2-4Mbps. Note that I tested wlan1 connection bandwidth to the remote server with Iperf and got up/down around 90Mbps. Both wifi interfaces use different channels and both wifi devices use original manufacturers drivers. I've tested it on Ubuntu Server 13.04 and Debian 7 with H/W ZBox and also Raspberry Pi. For WiFi interfaces I used Alfa AWUS036NHR Question: why when setting up AP wlan0 with eth0 (wireless <-> wired) outperforms by so much wlan0 with wlan1 (wireless <-> wireless)? Is it something to do with WiFi drivers or bridging both interfaces, or any other reason I missed out?

Here are my settings:

/etc/network/interfaces

auto lo wlan0 wlan1
iface lo inet loopback
#access point
iface wlan0 inet static
  address 192.168.52.1
  netmask 255.255.255.0
#connection to the internet
iface wlan1 inet dhcp
 wpa-supplicant /wpa_supplicant/wpa_supplicant.conf
up iptables-restore < /etc/iptables.ipv4.nat

/etc/hostapd/hostapd.conf

interface=wlan0
driver=nl80211
ssid=AP-1
hw_mode=g
ieee80211n=1
wmm_enabled=1
wme_enabled=1
ht_capab=[HT40-][HT40+]    
channel=6
#WPA2
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_passphrase=xxxx
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP

/etc/dnsmasq.conf

interface=wlan0
dhcp-range=192.168.52.5,192.168.52.254,255.255.255.0,12h

iptables & ipforward

iptables -t nat -A POSTROUTING -j MASQUERADE
echo 1 > /proc/sys/net/ipv4/ip_forward
share|improve this question

1 Answer 1

You can try to set the rate of both cards.

Iwconfig wlan1 rate 54M fixed

Also, what kind of wifi cards and are you using a usb hub?

share|improve this answer
    
If you want a more direct communication, you can ask to go on chat. Going "private" isn't really accepted here, because people who have this problem in the future will not be able to see how to fix it. –  Galgalesh Dec 30 '14 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.