Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT: This is not a duplicate of No sound on HDMI with Radeon driver. I have followed those instructions to update grub, and the problem persists.

I'm having no luck getting HDMI audio to work. I've searched around and read many many suggestions on how to fix this issue, but none have solved the problem.

  • Running Ubuntu 13.10
  • AMD Radeon Richland integrated APU
  • Onboard audio works fine
  • HDMI audio doesn't make a peep

Details:

$ lspci -nn | grep VGA

00:01.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Richland [1002:999c]

$ aplay -l

**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0`

$ cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version k3.11.0-15-generic

$ sudo lshw -c video
  *-display               
       description: VGA compatible controller
       product: Richland
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 1
       bus info: pci@0000:00:01.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=fglrx_pci latency=0
       resources: irq:53 memory:c0000000-cfffffff ioport:f000(size=256) memory:ff700000-ff73ffff

Things I've already tried:

  • Ensure HDMI is unmuted in alsamixer
  • Update alsa to latest daily build. Running oem-audio-hda-daily-dkms - 0.201402110705~ubuntu13.10.1
  • Update video driver from radeon to fglrx (catalyst 13.12). Initially HDMI audio was not listed among outputs under Sound Settings (although it was shown in aplay -l), but after installing fglrx driver, now HDMI audio is listed in Sound Settings.
  • Checked volume and settings in PulseAudio Volume Control - set HDMI audio to be the fallback output.

I'm at a loss what to try next.

Maybe the most telling error related to this is the one from speaker-test:

$ speaker-test -c2 -D hw:0,3 -r48000

speaker-test 1.0.27.1

Playback device is hw:0,3
Stream parameters are 48000Hz, S16_LE, 2 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 64 to 16384
Period size range from 32 to 8192
Using max buffer size 16384
Periods = 4
was set period_size = 4096
was set buffer_size = 16384
 0 - Front Left
Write error: -5,Input/output error
xrun_recovery failed: -5,Input/output error
Transfer failed: Input/output error

Any help is greatly appreciated!

Thanks

share|improve this question
    
I am not experiencing the fast video playback described in that post. Also, the alsa bug report at bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/864735 says that workaround #2 is install the proprietary catalyst drivers, which I have already done. –  Jugdizh Feb 12 at 2:07
    
FYI I did the grub update suggested in that post and it didn't resolve the issue. –  Jugdizh Feb 12 at 10:53
    
Are you aware that your issue is most likely a bug? –  Braiam Feb 13 at 22:42
    
A bug in the kernel, fglrx driver, elsewhere? Where would you suggest I report it? –  Jugdizh Feb 14 at 7:38
    
I would try another distro to see if it works there. Then following the guide of Debbuging sounds problems. That would help a lot. –  Braiam Feb 14 at 14:12

1 Answer 1

The fix for this was to upgrade the kernel to 3.13. After doing so I now have working HDMI audio, using either the radeon or fglrx driver.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.