Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu Server 12.04 for low-power home server (NAS mainly). System boots from USB pen-drive (to keep all IDE/SATA ports available for RAID, etc.). System will suspend when idle for time.

pm-suspend is working. sudo etherwake -D 00:11:22:33:44:55 (from another computer) wakes the server up and it is back on line in less than 15s. So far so good.

The problem is that on resume/wake-up the file system has changed to read-only. From my extensive searching this seems to indicate either (1) that the OS thinks the drive is going bad or (2) the system comes out of sleep before the USB drive is ready and so back to (1).

Can anyone suggest a fix for this?

Many thanks.

share|improve this question
    
Chas. Owens suggests changing the mount options for / in /etc/fstab to noatime,nodiratime,errors=continue. This seems to work. Is there any problem with this method? –  Transistor Feb 12 at 19:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.