Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Unity Launcher is currently stuck open. Short of logging out and back in, does anyone have ideas for getting it to auto-hide as usual?

share|improve this question
up vote 4 down vote accepted

It turns out that the Launcher is supposed to stay open on workspaces containing no windows. Two of my workspaces had maximised windows which Unity didn't seem to be noticing, and when I closed those and then re-opened them, the Launcher reverted to its correct auto-hide behaviour.

Perhaps one could also simply move the window to another workspace and back to get the Launcher unstuck--I did not think to try that.

share|improve this answer

If you wish to have the launcher always autohide, you can use the Unity plugin in the CompizConfig Settings Manager. See this question for complete instructions.

share|improve this answer
Very useful, thanks! I'm accepting my own answer because it is the answer to the very specific question that I asked, but voting yours up because it is great info. :) – Josh Glover May 11 '11 at 11:47

None of the methods above like Super S/Super-W, drag drops, min/max/move windows worked for me.

Only running ccsm, disabling Ubuntu Unity Plugin, and re-enabling it.

Ubuntu 11.10

share|improve this answer
Tried it... didn't work for me. :-( – Christopher Parker Mar 8 '12 at 16:51

I've had the same problems. SO annoying. It seems to happen when I select and drag in certain programs. So far in Menedely Desktop and QtiPlot. The trick I've found is to go to a web page select text then begin to drag and the sidebar will go back to auto-hide.

share|improve this answer
I wish it would get fixed!! – timmay143 May 20 '11 at 21:12
worked for me, thanks! – geoffrey May 31 '11 at 8:58

Yes, it's a bug. What i do is start the expo plugin using the shortcut key and the launcher hides after that.

share|improve this answer
OK, I'll try that if I encounter the bug again. If someone else can independently verify that this trick works, I'll accept this answer instead of mine. :) – Josh Glover May 15 '11 at 9:13
the trick does not work for me – geoffrey May 31 '11 at 8:58

timmay143's workaround helped me. The bug seems to be fixed now: Fix not released for Natty yet.

share|improve this answer
The Natty fix is now marked Fix Released. – Christopher Kyle Horton Feb 2 '12 at 10:29

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.