Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

TeamViewer gets shipped with Wine 1.6. Pulseaudio is working in installed wine 1.6.1 from PPA. Copying over the winepulse.drv.so and fakedlls/winepulse.drv does not work. You can approve this with teamviewer --winecfg.

I've tried running TeamViewer with local installed wine by uncomment the line

### USE_LOCAL_WINE="yes"

in /opt/teamviewer9/tv_bin/script/tvw_config. But that brings other errors.

May be we can update upgrade TeamViewers wine to 1.6.1 instead using local installed wine.

share|improve this question
    
I don't have enough rep to comment... To add to iRaS excellent answer, if you installed teamviewer first, then wine, a bad config/teamviewer9 may have been left over and not properly updated with "teamviewer --update-profile". If that is the case, when "teamview --wincfg" is run, you will not see any options to select when you are in the audio tab. I had to "rm -rf .config/teamviewer9", from my home directory, to get it to work. –  user266346 Apr 7 at 16:41

1 Answer 1

up vote 2 down vote accepted

Finally TeamViewer is running with sound.

This is what you need to do:

  1. Add wine repository and install wine1.6:

    sudo apt-add-repository ppa:ubuntu-wine/ppa
    sudo apt-get update
    sudo apt-get install wine1.6
    
  2. Download and install TeamViewer:

    wget http://download.teamviewer.com/download/teamviewer_linux.deb
    sudo gdebi teamviewer_linux.deb
    
  3. Copy over wine binaries:

    sudo cp /usr/bin/wine /usr/bin/wineserver /usr/bin/wine-preloader /opt/teamviewer9/tv_bin/wine/bin/
    sudo cp /usr/lib/i386-linux-gnu/libwine.so.1.0 /opt/teamviewer9/tv_bin/wine/lib/
    sudo cp -R /usr/lib/i386-linux-gnu/wine/* /opt/teamviewer9/tv_bin/wine/lib/wine/
    
  4. Reconfigure your teamviewer profile and start winecfg to see if audio is working.

    teamviewer --update-profile
    teamviewer --winecfg
    
share|improve this answer
2  
I don't have enough rep to comment... To add to iRaS excellent answer, if you installed teamviewer first, then wine, a bad config/teamviewer9 may have been left over and not properly updated with "teamviewer --update-profile". If that is the case, when "teamview --wincfg" is run, you will not see any options to select when you are in the audio tab. I had to "rm -rf .config/teamviewer9", from my home directory, to get it to work. –  user266346 Apr 7 at 16:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.