Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Firefox becomes default browser after upgrade. Cannot revert to Google Chrome

I installed Chromium. It worked well. But I could not set it as default. It was there in my Dash, but every time I opened it, it asked me whether I want to set it as default. I even tried changing it in the Preferences. I could click on Make it my default browser but it didn't make a change.

So I installed Chrome Beta. It worked well initially. Following a last update (12.0.742.30 beta) this problem has started again.

Is this is a bug? or is it just me? and how can I make Chrome remember my preference?

(P.S. I don't want to switch to the stable channel.)

[Update: I found a workaround that I select 'do not ask me again' when it asks me for my preference. This stops the annoying messages, and since Chrome is the only browser on my Natty currently it is default in any case. But this restricts me from installing any other browser.]

share|improve this question

marked as duplicate by Marco Ceppi May 11 '11 at 6:01

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

You can change "Preferred Applications" under System \ Preferences \ Preferred Applications (Classic Gnome) in Unity push the on\off button and go through the settings to Preferred Applications.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.