Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two servers running 13.04, and at some point I added the oldstable package sources for PHP 5.4. For some reason I'm not able to update it anymore though — one server doesn't upgrade from 5.4.23 to 5.4.24, and the other one, after a few troubleshooting uninstalls is stuck with 5.4.9 from the default package sources.

Here's the correct version installed on one server:

PHP 5.4.23-1+sury.org~raring+1 (cli) (built: Dec 12 2013 09:25:05)
Copyright (c) 1997-2013 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies

Here's what I did on the other server:

# add-apt-repository ppa:ondrej/php5-oldstable
# apt-get update && apt-get upgrade

But, I get the old version:

# php -v
PHP 5.4.9-4ubuntu2.4 (cli) (built: Dec 12 2013 04:29:20)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

I already did an apt-get remove php* --purge, followed by an apt-get install php5, but no dice: it brought me down from 5.4.23 to 5.4.9.


Here's the correct selections I need installed:

# dpkg --get-selections | grep php
libapache2-mod-php5         install
php-apc                     install
php-pear                    install
php5                        install
php5-cli                    install
php5-common                 install
php5-curl                   install
php5-gd                     install
php5-imagick                install
php5-mysql                  install

The cache doesn't even show the PPA:

# apt-cache policy php5
php5:
  Installed: 5.4.9-4ubuntu2.4
  Candidate: 5.4.9-4ubuntu2.4
  Version table:
 *** 5.4.9-4ubuntu2.4 0
        500 http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ raring-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ raring-security/main amd64 Packages
        100 /var/lib/dpkg/status
     5.4.9-4ubuntu2 0
        500 http://eu-west-1.ec2.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
share|improve this question

closed as off-topic by Olli, Jorge Castro, mikewhatever, Mateo_, Braiam Feb 13 at 0:04

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
but php5 version 5.5.3 is available on the repositories. –  Avinash Raj Feb 11 at 13:23
    
I don't care about 5.5.3 — I need the latest 5.4 from the oldstable repositories so that the two servers run the same PHP version. –  slhck Feb 11 at 13:24
    
If you run apt-cache search php5 does a option show to install "5.4.24-1+sury.org" ? –  dash-plus-java Feb 11 at 13:56
    
@DashplusJava No, it just lists all kinds of packages without specific version names. –  slhck Feb 11 at 14:08
    
Try this command please: sudo apt-get install php5=5.4.24-1+sury.org –  dash-plus-java Feb 11 at 14:11

1 Answer 1

up vote 5 down vote accepted

The reason you are unable to install the package you want is because it is no longer in the PPA that you added. The php5 5.4.23-1+sury.org for raring was removed from the PPA.

Here's what the PPA looked like on Dec 16, 2013 : http://web.archive.org/web/20131216111917/https://launchpad.net/~ondrej/+archive/php5-oldstable

You can see that at that time there was a raring package for php5 in the PPA. This is what your other servers have installed. If you look at it today, that package is not there. Ubuntu will not remove a package that has been installed; so your other servers will still have it.

The reason for removing that package from the PPA is probably because Ubuntu 13.04 has ran out of support. It stopped receiving updates in January. Anyone still on 13.04 should upgrade to 13.10.

share|improve this answer
1  
Yep, that was it. I could copy the old .debs from /var/cache/apt though and install them with dpkg – seems to have worked. –  slhck Feb 11 at 14:56
    
Exactly, I don't support outdated Ubuntu releases. You should use LTS release if you want to have it for longer time. (BTW I will be phasing out quantal as well in a very short time, since it's support ends April 2014.) –  oerdnj Feb 14 at 17:44

Not the answer you're looking for? Browse other questions tagged or ask your own question.