Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am newer to Ubuntu and I am trying to slowly learn. I have been trying to activate and change my login sound but currently I still hear nothing. I did hear the login sound at a point and I think I messed it up when I changed the file.
This is what I have done. I added a startup application with this command I pasted in,/usr/bin/canberra-gtk-play --id="desktop-login" --description="GNOME Login sound". I then typed in gksu nautilus and went to /usr/share/sounds/ubuntu/stereo and I changed two files,desktop-login.ogg and system-startup.ogg, at least that is what I renamed them. I renamed the old desktop-login.ogg to system-startup.ogg, which I thought was that files original name in the same folder just to move it out of the way and keep the sound. I brought in a new .ogg file and renamed it desktop-login.ogg in hopes that the new file would take hold and play in the old files place upon startup/login. I currently get no sounds. Can anyone find my error? My first thoughts are that the name I made, system-startup.ogg, was not the original name.

share|improve this question
    
i think its the wrong way to change the physical files, take a look at linuxandlife.com/2012/05/… - this may be helpful –  Wolfgang Vogl Feb 11 at 11:05

1 Answer 1

up vote 1 down vote accepted

1) Open Terminal and enter this command: gedit ~/.config/autostart/loginsound.desktop

2) Copy and paste the text below into this new blank file:

[Desktop Entry]
Type=Application
Exec=/usr/bin/canberra-gtk-play --id="desktop-login"
Name=Login Sound
Comment=Play login sound on startup
Icon=multimedia-volume-control
Hidden=false
NoDisplay=true
X-GNOME-Autostart-enabled=true

3) Exit gedit saving the modified file.

4) Make sure that you have a file named /usr/share/sounds/ubuntu/stereo/desktop-login.ogg and it does play your preferred login sound - you can try Terminal command /usr/bin/canberra-gtk-play --id="desktop-login" and if you don't hear anything there might be something wrong with that file: 1) does it really contain any sound? 2) does it have read permissions for all? which you can check via gksu nautilus command and Properties context menu item.

share|improve this answer
    
Im not sure if I still needed the code you gave me but after that didn't work I checked the file and indeed it didn't allow any read privileges. –  Cliffbrowning84 Feb 11 at 12:55
    
You can of course achieve this in various ways, but I think this is a good method for enabling login sound in Ubuntu as it is also displayed in Startup Applications (GUI) applet. –  Sadi Feb 11 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.