Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dual-boot machine. The internet is perfectly fine when I use Windows; I can access all websites normally.

However, when I change to Ubuntu, I can no longer access Facebook, Twitter, YouTube, etc.

What is going on? What should I do to get this fixed?

Edit :

My DNS : 8.8.8.8, 8.8.4.4

From ifconfig

eth0      Link encap:Ethernet  HWaddr 50:46:5d:3f:f5:09  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2515 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2515 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:202999 (202.9 KB)  TX bytes:202999 (202.9 KB)

wlan0     Link encap:Ethernet  HWaddr dc:85:de:a4:e4:7d  
          inet addr:192.168.0.102  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::de85:deff:fea4:e47d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:11092 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9984 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7149295 (7.1 MB)  TX bytes:1679041 (1.6 MB)

From ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 1000
    link/ether 50:46:5d:3f:f5:09 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether dc:85:de:a4:e4:7d brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.102/24 brd 192.168.0.255 scope global wlan0
       valid_lft forever preferred_lft forever
    inet6 fe80::de85:deff:fea4:e47d/64 scope link 
       valid_lft forever preferred_lft forever

I can ping www.google.com (0% lost), but when i tried to ping www.youtube.com, only forever loading happened here :

PING www.youtube.com (46.82.174.68) 56(84) bytes of data.

When i run nm-tool | tail -n 8 :

IPv4 Settings:
    Address:         192.168.0.102
    Prefix:          24 (255.255.255.0)
    Gateway:         192.168.0.1

    DNS:             192.168.0.1

Please help me.

share|improve this question
    
are you on a PPPoE connection?? –  Meow Feb 11 at 10:49
    
@Meow Sorry what is that?im a beginner in networking. I just use a normal internet connection without proxy, etc –  Blaze Tama Feb 11 at 10:51
    
okay do you have a router or do you connedt directly to modem and what is your "ifconfig" output –  Meow Feb 11 at 10:55
    
Is it only few sites or all websites?? Also open a terminal using CTRL+ALT+T & type ping google.com, then see whether site is reachable. If you don't understand, you may edit your question & post the output here. –  AzkerM Feb 11 at 10:56
    
Done, please help me out. Thanks :D –  Blaze Tama Feb 11 at 11:04

1 Answer 1

up vote 1 down vote accepted

try

 sudo ifconfig eth0 mtu 1450 
 sudo ifconfig wlan0 mtu 1450
share|improve this answer
    
Thanks very much for your help. Could you kindly tell me how to make this change permanently? –  Blaze Tama Feb 11 at 11:53
    
add the line mtu 1450 at the end of file etc/network/interfaces –  Meow Feb 11 at 11:56
    
gksu gedit etc/network/interfaces –  Meow Feb 11 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.