Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Natty with a clean install on a MacBook Pro (with no OSX install) and currently loving the switch! I found the area in keyboard layout options to map ctrl to the win keys (and the usual ctrl keys) and that turned my command key into a ctrl key which I'm used to from mac osx (working perfectly yesterday.)

However, now when I try, it's not working and the settings are still the same... I've tried to add different keyboards (worked with my original Canada English default yesterday... tried US Macintosh and set Keyboard Model to MacBook Pro (both regular and intl, neither worked.)

It was really weird because for a second my right command key was working as expected but not the left, and now neither are working.

Any thoughts or suggestions would be greatly appreciated.

share|improve this question
    
I have the same issue. –  zookalicious May 13 '11 at 13:29

1 Answer 1

Figured it out! The default of having the Dash set to the Mod4 key (Command key) apparently causes several problems (aside from annoying me).

I solved this problem by changing the key that triggers the Dash from the Command (Mod4) key to something else. In my example I used the F1 key but I think any single key should be fine.

Simply type the following in a terminal to change the Dash from Mod4 to F1.

 gconftool --set /apps/compiz-1/plugins/unityshell/screen0/options/show_launcher --type=string "F1"

Now when you select "map ctrl to the win keys (and the usual ctrl keys)" it should work as expected! And if you need access to the dash you can activate it by hitting the F1 key, 4-finger tapping the trackpad (on devices that support it), or clicking the ubuntu logo in the top left.

(Note: I am using Unity 3D)

share|improve this answer
1  
I also filed a bug report here: bugs.launchpad.net/unity/+bug/782329 Make sure to click here if this bug affects you and let the Unity team know. It just takes one click. –  zookalicious May 16 '11 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.