Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I tried to load Ubuntu 12.04 onto an old machine from a CD and the installation went fine, but I got the boot error: no such device: grub rescue.

I looked into the issue with a CD live boot (unsure of the terminology, but I selected the option to try Ubuntu Desktop) and found this forum post suggesting a Boot Repair program. I installed it from the terminal. I ran the program, it said it was fixed, and I tried to start it up no no avail. It gave me an Ubuntu Pastebin and to ask if I had any troubles.

What should I try now to fix this?

I am not very educated in programming or Linux type operating systems yet. But I would appreciate any help and will try to give as much information as necessary.

So far the only way my access desktop is using the installation disk.

share|improve this question
    
May I ask what was the previous operating system installed on the computer? how did you exactly installed (by partitioning or similar)?... etc –  AzkerM Feb 11 at 6:31
    
The previous operating system was Windows XP Home Service Pack 3. The way I installed was by burning a CD and booting the system through the boot menu with the CD-ROM drive. I told the installer to remove Windows XP and to install only Ubuntu 12.04. –  DarkAngle Feb 11 at 23:49
    
have you tried askubuntu.com/questions/88384/… ? –  whale_steward Feb 12 at 2:56

1 Answer 1

Reinstall GRUB using the live CD.

Steps are available here: Boot error > no such device: grub rescue

share|improve this answer
    
It said that it finished the installation, but upon restart I encountered the same error. –  DarkAngle Feb 11 at 23:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.