Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Ubuntu 12.04 LTS on my external hard drive and it works fine on the computer it was originally installed from. But when I attempt to boot the external drive from another computer; all I get is black screen with a blinking underscore.

Do I have to install any similar application/service on each computer or to change anything with grub? I already know about the USB live CD but this is a full installation of Ubuntu that I want to boot,

Am I doing anything wrong or is there a possible way to succeed?

share|improve this question
    
When does the blinking underscore happen? Does it get to the "try or install ubuntu" page? –  Parto Feb 11 at 6:48
    
It's already installed it's not a live CD or USB, it's a full instalation –  user246923 Feb 11 at 15:55
add comment

1 Answer 1

by no means an expert but I would assume that an "installed" Ubuntu is to an extend tailored to its HW. I can therefore see that moving the disk to other HW would lead to issues. I would likewise also expect that the Bootloader is very generic. So can you get to the bootloader screen e.g GRUB. If so I think that selecting recovery mode would then be your best try to see whether you can get some indication of what the machine is telling you when trying to boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.