Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed Ubuntu 13.10 on my Dell Latitude D630. I'm new to Linux and don't know too much about it. I've researched a few solutions to this problem, but none have worked, or I couldn't complete the steps.

One main problem is that when I'm using the terminal, every once in a while it just stops and when I try to close it, it warns me that a process is running.

I've been trying to get ndisgtk to install the appropriate driver, but the terminal does that thing and when I tried to just go though the online sources, it just froze on the side bar saying "preparing to install" or some such and made no progress.

Is there any way I can solve the wireless issues?

snarky@snarky-Latitude-D630:~$ lspci -nn | grep 0280
0c:00.0 Network controller [0280]: Broadcom Corporation BCM4311 802.11b/g WLAN [14e4:4311] (rev 01)
share|improve this question
I doubt that ndiswrapper is correct for your device. Please edit your question to add details of your wireless device from the terminal command: lspci -nn | grep 0280 – chili555 Feb 11 '14 at 0:46

Please get a temporary wired ethernet connection, open a terminal and do:

sudo apt-get remove --purge ndiswrapper*
sudo apt-get remove --purge bcmwl-kernel-source
sudo apt-get install firmware-b43-installer

Note that, as mentioned in the comments, firmware-b43-installer was formerly linux-firmware-nonfree.

Detach the ethernet, reboot and let us hear your report.

share|improve this answer
For debian the package is called "firmware-linux-nonfree" ... probably the same for ubuntu. – Alex Oct 7 '14 at 14:30
Not the same in Ubuntu. – chili555 Oct 7 '14 at 15:22
Didn't work with ubuntu – user76369 Aug 31 '15 at 1:17
@user76369 Do you have firmware-b43-installer installed? If so and it still doesn't work, I suggest you start your own new question. – chili555 Aug 31 '15 at 14:07
@user76369 At the time I posted this answer, some 18 months ago, the correct package was linux-firmware-nonfree. Now, in late 2015, it is, as I stated, firmware-b43-installer. I don't expect to revisit all of my thousands of posts back for a decade and update them. – chili555 Sep 1 '15 at 19:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.