Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm recently trying to get a version of Linux (specifically Ubuntu) installed on my surface pro as the host OS. I've followed a few tutorials which all have the almost the same instructions and for some reason am still having troubles. I've also tried multiple distros including: Ubuntu 13.04/13.10, Ubuntu 12.04 LTS, kubuntu 13.04, latest version of Mint, and a few other random distros. With all of them I get the same outcomes:

  • Live CD works fine (no internet)
  • Install goes smoothly; no errors at all
  • After install if I reboot into a live USB the hard drive of the surface shows Ubuntu was installed
  • I can access and change files on the hard drive
  • When using a bootable Windows 8 USB it shows that the hard drive does indeed have Ubuntu on it.

The problem is that if I turn on the surface with a bootable USB drive it goes straight into the drive and if I turn it on without a bootable drive it just goes to the BIOS that the surface has. I've tried to manually install GRUB but that hasn't worked either. Any solutions would really be helpful!

Link to tutorial I've been using mainly, although most of them are along the same lines: http://www.geek.com/microsoft/how-to-install-ubuntu-on-the-surface-pro-1539262/

Also, once I was able to boot into Ubuntu and get to the login screen but when I would only have a few seconds before the entire system froze. Getting here is random and has only been reached using Ubuntu/Kubuntu.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.