Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new on Ubuntu. I want to limit the disk space per user. For example: Jhon Doe 10gb, Jane 20gb, and so on. I wrote the following code as root: gedit /etc/fstab . In the new window I got this:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/HFUserver-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/sda1 during installation
UUID=74b91621-bc0c-4a48-8d35-49b1fdd31542 /boot           ext2    defaults        0       2
/dev/mapper/HFUserver-swap_1 none            swap    sw              0       0

What do I need to change?

share|improve this question
2  
This is called "quota" in Unix/Linux. A nice (external) link is here: thegeekstuff.com/2010/07/disk-quota –  Rmano Feb 10 at 20:58
    
@tech-support I can't understand. Please edit your answer adding the step you did and what does not work. Your last comment doesn't parse... –  Rmano Feb 11 at 20:18
    
I wrote the following code on terminal: gedit etc/fstab I added the following code at the end of the lines: # cat /etc/fstab LABEL=/home /home ext2 defaults,usrquota,grpquota 1 2 I rebooted the server. Now I got the following message. The disk drive for /home is not ready yet or not present. keys: continue to wait, or press S to skip mounting or M for manual recovery. What can I do? I am new on Ubuntu. –  Tech_Support Feb 11 at 20:22
    
I removed quota to see if the problem is resolved, but the problem continues. –  Tech_Support Feb 11 at 20:40
    
Please show the /etc/fstab file you had before your changes. And please add the info to the question, comments can't be formatted easily. You should have just added the usrquota,grpquota in the options in the entry you had before for your /home partition... –  Rmano Feb 11 at 21:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.