Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got this Lenovo z710 for christmas and decided to remove the preinstalled Windows 8 and install Ubuntu 12.04 instead. However, I can't connect to any networks, wired nor wireless.

I've been reading up on my issue for weeks now and haven't found a working solution. I deleted all of my partitions last night and did a fresh install so hopefully I can work through this more easily.

First thing I've tried is:

iwconfig

Which outputs:

eth0       no wireless extensions
lo         no wireless extensions

Network card is a Broadcom BCM43142 PC-ID: [14e4:4365]

rawberry@rawberry-pc:~/Desktop/test$ lspci -vnn -d 14e4:
01:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Lenovo Device [17aa:0611]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at b0500000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>
    Kernel driver in use: bcma-pci-bridge

Maybe some of this might help, I'm still very new to Linux so I'm not sure what exactly this all means...

rawberry@rawberryPC:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 0c:54:a5:14:0b:ce  
          inet6 addr: fe80::e54:a5ff:fe14:bce/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:331 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:73757 (73.7 KB)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:432 errors:0 dropped:0 overruns:0 frame:0
          TX packets:432 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:34832 (34.8 KB)  TX bytes:34832 (34.8 KB)

rawberry@rawberryPC:~$ sudo lshw -C network
[sudo] password for rawberry: 
  *-network UNCLAIMED     
       description: Network controller
       product: Broadcom Corporation
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:b0500000-b0507fff
  *-network
       description: Ethernet interface
       product: Atheros Communications Inc.
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 10
       serial: 0c:54:a5:14:0b:ce
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx driverversion=1.2.3 duplex=full firmware=N/A latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:18 memory:b0400000-b043ffff ioport:3000(size=128)

Any insight on my issue would be immensely appreciated, thanks!

share|improve this question
    
does wifi or wireless work when you boot from LiveCD? –  danijelc Feb 10 at 18:05
    
No, neither does –  rawberry Feb 10 at 18:08
    
From what I think I understand from my prior readings, I have either broadcom or atheros network drivers and I'll need to manually update the firmware. I'm seeing both broadcom and atheros from the terminal info though, so I think I'm missing something. –  rawberry Feb 10 at 18:12
    
The Atheros network card is working properly but it's your wired connection. Your wireless is Broadcom, and you probably lack drivers for it. The safest first option is to try the most current LiveCD possible (right now the 14.04 alfa) and check if wireless works there. –  Javier Rivera Feb 10 at 18:22
1  
Actually, upon further use I've gotten some results. I was unable to connect with firefox while wired. However, I was able to update my broadcom drivers using the update center and my wifi started working immediately after, even when unwired. I'm only running the live cd right now, but am seriously considering just installing and using 14.04 –  rawberry Feb 12 at 19:33

1 Answer 1

up vote 0 down vote accepted

So working through this issue was an absolute pain in the ass for me. It was my first venture into the linux realm, and at times it was quite taxing on my soul. Hopefully I can outline clearly enough the steps I took to identify the exact issue and solve it.

Note: All of these steps were taken successfully using Ubuntu 14.04 downloadable here: http://cdimage.ubuntu.com/daily-live/current/

First thing I would do is check what driver your network card is currently using

lspci -v

Look for your network controller and check the line:

Kernel driver in use: <driver>

If your network controller is not using the wl driver, then I would next check that the wl module is installed using lsmod to list all installed modules.

lsmod

If you do not see wl listed under the Module list, there's the problem.

If you do in fact see wl listed, then you most likely just need to force your network controller to use the proper driver. I think this can be done with sudo modprobe wl but I'm really not certain. Best to research some more elsewhere (Don't fret, your closer than everyone else!)

Or you can follow these next steps and it should work as well, just with more effort than you really should have to put in.

So you don't have your wl module which is bad. The next step is to purge your bcmwl-kernel-source

sudo apt-get purge bcmwl-kernel-source

Since I had no internet access, I was forced to boot into the 14.04 live cd, where I could gain internet access wirelessly after opening Software & Updates going to the additional drivers tab and enabling the BCM proprietary driver.

After you've done this, install the Synaptic Package Manager from the Ubuntu software center.

Then follow these steps outlined by Sneetsher, with additional packages that I installed.

Use live CD, Use Synaptic > Settings > Repositories: check all. Then Reload (to update package list). Check linux-firmware , linux-firmware-nonfree, bcmwl-kernel-source, dkms, all linux-headers, and all linux-image-extra for installed kernels. Then File > Generate download script. Save it in the desktop. Run it. Save packages to USB key. Reboot to installed OS, use sudo dpkg -i *.deb to install them. Reboot, see if it works?

See here: https://help.ubuntu.com/community/SynapticHowto for clarification on creating the script

After doing this hopefully your wireless will work! If not, I'm sorry, keep researching!

share|improve this answer
    
To further clarify on fixing wifi for this particular wireless card with this particular hardware, I ran into problems once again after updating my kernel and my wifi stopped working once again. It seems updating the linux-headers for the new version is all that needs to be done. Immediately after updating my headers to the proper version my wifi kicked back on. –  rawberry Sep 19 at 15:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.