Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was just thinking to myself that I was finally getting on OK with Unity when all of a sudden my keyboard stopped working. It's not a hardware issue: I've made no hardware changes, and the keyboard does work to enter login password, and it works perfectly in KDE, which I've now switched to using.

In Unity, no keystrokes get through. I can't even use system escape sequences, can't switch to a virtual terminal, nothing. I am using an Acer laptop. I plugged in an external, known good USB keyboard - still no keystrokes are accepted. I tried using the Onboard soft keyboard - that doesn't work either. The only input device that still works is the mouse. The only way I've found to get character input into the system is via LibreOffice's Insert Special Characters dialog! (The Ubuntu/Unity Character Map application does work but it doesn't offer the option to enter numeric digits!).

I've tried all the different input method options I can find via system settings/language preferences etc., logging out & in, rebooting... Nothing makes any difference.

What has changed in the system? All I can say is that I generally go right ahead and apply any and all updates that the software updater suggests, so the system ought to be right up to date.

mark@MES3810:~$ uname -a
Linux MES3810 3.11.0-15-generic #25-Ubuntu SMP Thu Jan 30 17:25:07 UTC 2014 i686 i686 i686 GNU/Linux

Any ideas where I can start looking to diagnose this (bearing in mind that keyboard input in Unity isn't working)?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.