Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a computer for my Wife, windows (her choice not mine). Before we paid, I asked the salesman to check whether my hard drive would work with windows 7 (as sometimes windows can be iffy). It worked fine, however, the salesman yanked my hard drive out without removing it safely. Now it wont mount, in my Ubuntu computer or her new windows. I've tried a lot of instructions but none work.

This is what I'm up against:

sammy@Fart:~$ sudo fdisk -l

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00077cf7

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848    20482047    10137600    7  HPFS/NTFS/exFAT
/dev/sda3        20482048   177605687    78561820    7  HPFS/NTFS/exFAT
/dev/sda4       177606654   976771071   399582209    5  Extended
/dev/sda5       177606656   971016191   396704768   83  Linux
/dev/sda6       971018240   976771071     2876416   82  Linux swap / Solaris

Disk /dev/sdb: 500.1 GB, 500107861504 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773167 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xe640222c

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63   976768064   488384001    7  HPFS/NTFS/exFAT

So, would I be right in presuming that my hard drive is /dev/sdb1 ?

I tried to mount it manually and got this error message:

sammy@Fart:~$ sudo mount -t ntfs /dev/sdb1 /media
Error reading bootsector: Input/output error
Failed to mount '/dev/sdb1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

I tried to run chkdsk /f on windows but it would not run due to my disk already being used by another process. Now I'm stuck. I'm not new to ubuntu but I'm not a computer whizz either. I don't really know anything about softraid/fakeraid and have no idea what to do.

Any help would be very much appreciated.

P.S. (To answer the first question you may have on your mind, yes I regret calling my computer "fart")

Thanks alot,

Sammy

Update: I've now successfully completed check disk and it hasn't solved a thing. Nothing suggested has worked and I've run out of ideas.

share|improve this question
1  
Try checking the disk from within windows, by right clicking, choose Properties --> Tools Tab --> and Check. Let me know. –  Mitch Feb 10 at 8:21
    
Hi Mitch,Thanks for your reply. Unfortunately the disk wont mount in Ubuntu or Windows. Although in Windows it does register when you click the safely remove drive icon as an unknown usb device. I've tried safely removing it and plugging it in again a few times but to no avail. I can also see it in run chkdsk /f but get stuck there without actually being able to check the disk. There's no way I can find to right click the disk, although the windows machine I'm using is Chinese and navigation is a problem. (I'm in China) How would one right click an unmounted disk? Thanks again, Sammy. –  Klubijar Feb 10 at 9:55
    
Take a look at askubuntu.com/questions/74105/…. Does it help? –  Mitch Feb 10 at 10:49
    
I've been able to run a dskchk on windows now but I'm unable to boot windows after the disk check. I'm going to try it again on another pc but, I didn't seem to work. I tried "sudo ntfsfix /dev/sdb1" but I got "Mounting volume... Error opening '/dev/sdb1': No such device or address FAILED Attempting to correct errors... Error opening '/dev/sdb1': No such device or address FAILED Failed to startup volume: No such device or address Error opening '/dev/sdb1': No such device or address Volume is corrupt. You should run chkdsk." On windows I can't even get to the stage were I'm able to right click –  Klubijar Feb 11 at 2:14
    
Thanks again mitch. :) –  Klubijar Feb 11 at 2:16

2 Answers 2

Already answered: Fix corrupt NTFS partition without Windows

Please try and see if it matches your case, using Gparted is a highly recommended solution, saved a lot of hassle for me (although all the other options suggested there are quite good as well).

share|improve this answer
    
Hi Yaron, thanks for your input. I had a look at that post and I'm not sure it matches my case. I'm unable to see my troubled external hard drive using gparted or test disk. Also none of the terminal instructions seem to help. Thanks anyway. –  Klubijar Feb 11 at 2:54
    
If it's a USB drive, can you please remove it from it's case and adapter and try to connect it to your PC directly? (If it's a laptop it might be a little complicated). –  Yaron May 2 at 14:25

From own experience: 'ungraceful' detachment of a removable device resulted in inconsistent reference to the volume's first sector in the mbr partition table.

Using a Disk editor (e.g. wxHexEditor), locate the ntfs boot sector. Make sure this lies on sector 63 (64th sector).

Tas

share|improve this answer
    
This is entirely wrong. Nothing changes in the partition table, and the boot sector is normally on sector 2048 these days, not 63. You also didn't say what to do if it isn't there ( or how to tell ), and in any case, it's location is also completely unrelated to an ungraceful removal. –  psusi Mar 27 at 19:32
    
Thanks for correcting my answer,however,no matter how wrong or unrelated may sound to you,that's what happened to a usb drive of mine. The entire sector was filled with garbage, this case looks a little different. How to tell? You simply examine the sector #63 with a disk editor. If it isn't there you could search for a sector starting with eb-52-90-(NTFS etc.) and ending with 55aa. You are right though, these days, 63 seems highly unlikely for the first sector of an ntfs volume. If 63 is not bogus, the device might be an originally FAT formatted drive, later re-formatted as ntfs. cheers Tas –  Tas Mar 27 at 21:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.