Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, this is what is happening, i've downloaded a game that is supposed to run in playOnLinux perfectly, however, when i'm trying to play, it gives me an error "Shader Version 3.0 is not supported", it does not matter if i configure the lowest settings or not, it gives me the same error, my graphics card is a GeForce (Nvidia) 610, 1gb dedicated.

Then i checked the 'log' of the game, it says this.

Xlib:  extension "GLX" missing on display ":0.0".
[02/09/14 21:14:44] - Running wine-1.7.12 launcher.exe (Working directory : /home/david/.PlayOnLinux/wineprefix/WarThunder/drive_c/Program Files/WarThunder)
[02/09/14 21:14:48] - Running wine-1.7.12 launcher.exe (Working directory : /home/david/.PlayOnLinux/wineprefix/WarThunder/drive_c/Program Files/WarThunder)
File already exists.

Then i think on the glxinfo options, and this is the output:

david@iris:~$ glxinfo
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual or fbconfig

Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".

I've tried by now reinstalling nvidia-current package, as well as every package of mesa utilities, i really ran out of options, i've seen also many answers on the post with no luck.

Thank you in advance to all who can help me.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.