Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a relatively old MacBook that I would like to recycle as a Ubuntu Linux Server. However the laptop has only a partially working keyboard (not all the keys, and notably, but not only, the left and right arrows and the Return keys, are not working). Therefore I would like to make a headless installation (via SSH) or a network installation. I've done the former on a Raspberry Pi and it worked great.

I am trying to connect the Old MacBook to my working Mac through Ethernet. In order to do so, I shared my working Mac's Ethernet port with Internet Sharing (that is what I did with the Raspberry Pi and it worked great).

I have downloaded and dd'd a thumb drive with the ubuntu-13.10-server-amd64.iso file (sudo dd if=ubuntu-13.10-server-amd64.iso of=/dev/rdisk3). Unfortunately, the thumb drive is not writable. chmod-ing the files do not work: the whole disk is viewed as a CD-ROM.

The recyclable Mac has rEFInd installed and recognizes the thumb drive with Ubuntu-Server 13.10 and I'm even able to start the computer on it. However I am stuck because of the faulty keys, hence the idea to install via ssh...

The questions are:

  • is there a way to make a non-writable USB thumb drive writable? I would like to circumvent some of the installation phases as suggested on this website: http://www.conrad.id.au/2012/06/installing-linux-on-headless-hp.html
  • is there another way to install Ubuntu-Server 13.10, like via network, if yes, is there a step-by-step description on how to do that (reminder: installation is done from a Mac to another Mac).

Thanks in advance for any answer,

pdeli :)

++++

share|improve this question
    
I am no expert about server installation nor about Ubuntu on a mac but I was wondering couldn't you plug in a external keyboard for the first setup? –  Wouter Feb 9 at 21:18
    
Hello. No. I don't have any wired keyboard at home (a few wireless/BT ones). And also: it is fun trying to find a solution for this kind of problem: I managed for the RPi, why not for a Mac? :) –  pdeli Feb 10 at 21:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.