Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Awhile back, I switched Internet plans and got a new router. Since then, I cannot connect to the new network with my Dell laptop running Ubuntu 12.04 Precise Pangolin. I believe connecting to a new wireless network should be as easy as clicking the wireless drop down menu at the top right, and then clicking the network ID. When I do this, nothing (literally, nothing) happens.

When I go down to 'Edit Connections' and try to add a new wireless network, all the options are greyed out. I can't enter or click anything. I have no problems whatsoever connecting and using other wireless networks which I previously added with no trouble at all.

I thought this may be a permissions thing (somehow), since I have recently tried out some different window managers, and just recently re-installed Unity. I attempted to set up a new connection from the command line, following the instructions from here, but this didn't work (even though none of the commands returned an error). I'm not familiar enough with any of these utilities and their output to know what the problem is.

I was stuck following the instructions like a recipe; not a good situation. I ran dmesg through grep searching for the interface name, and got several of these: ADDRCONF(NETDEV_UP): wlan0: link is not ready

Since I did all this, I have connected successfully to other wireless networks. There are numerous other wireless devices on the my home network, and there is no trouble with connecting with any of them.

I would much appreciate some help with this problem!

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.