Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I know this problem has been raised several times, but I have spent nearly four days, but I couldn't solve my problem. I just bought a Sony laptop that came preinstalled with Windows 8 with these specs: i5 CPU/4GB RAM/500GB HDD/1GB Nvidia GeForce 740M graphics.

I installed Ubuntu successfully in UEFI mode and secure boot disabled alongside Windows, but I didn't get any Grub bootloader. The problem was not solved even by boot-repair.

Then I tried Kubuntu, but this one wasn't even booting from the flash drive in UEFI mode and I was was compelled to change the mode to legacy which subsequently helped, but the same Grub problem persists. The mode has to be changed to legacy from boot setup each time I require to boot Kubuntu/Ubuntu and back to UEFI to boot Windows.

share|improve this question

1 Answer 1

See the following pages:

Broadly speaking, my recommendation is to use rEFInd's USB flash drive or CD-R image to boot to Ubuntu, then install the Debian package (from the same page) to get it working permanently. (You may need to mount your ESP to /boot/efi before installing the Debian package.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.