Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a Dell Latitude laptop E6530 with Win 7 Enterprise 64-bit with virtualization support enabled. I do not have TPM enabled. I've installed VirtualBox 4.3.6. When I try to install Ubuntu 13.10 desktop 64-bit I get this error:

This kernel requires an x86-64 CPU, but only detected an i686 CPU. 
Unable to boot - please use a kernel appropriate for your CPU.

Virtualization is working on this hardware and host OS because I use the HAX hardware accelerator for Android emulation on it.

Will enabling TPM solve this problem, or do I need another Linux distro?

share|improve this question

marked as duplicate by Takkat, Eric Carvalho, karel, Avinash Raj, BuZZ-dEE Feb 9 at 12:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

The problem was that in the VirtualBox settings I had to tell it that I was installing Ubuntu (64 bit) instead of just Ubuntu.

share|improve this answer
    
Even if you solved your own question, you should mark it as "solved" so other people with the same problem can find the answer easily. –  darent Feb 8 at 21:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.