Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have desktop with Asrock 990FX with two SSD disks. The first disk is used for Windows 8.1, the second disk I would like to use for Ubuntu.

I did boot a USB stick as UEFI, installation passed successfully and after reboot I get:

no boot media found

Regression:

  • I've also tried to install Ubuntu 12.04 LTS.
  • I do press F11 during desktop startup in order to choose boot device.
  • I can boot USB stick in UEFI mode. I see it in options.
  • Ubuntu reports that it was been installed on separate HDD.
  • I do reboot and... see Insert boot media.
  • I try to boot as default (Ubuntu HDD goes first in boot list). No luck.
  • I try to boot from Ubuntu HDD using special menu (F11). No luck.
  • It's impossible to boot Windows 8.1 by selecting it's HDD in the list. I have special menu item "Windows boot manager". If I click on it, it runs.

Looks like Ubuntu should have a similar menu item, but it doesn't.

What do I do wrong?

share|improve this question

1 Answer 1

Boot from your install media and take a look at your installation's /boot/grub.grub.cfg file. The disks may be "misnumbered/misnamed" because when the file was generated, the USB stick was present and might have bumped up the disk numbers (and letters) by one. If you have just the two SSDs, you expect one to be hd0 and the other to be hd1 in the grub.cfg file.

If you see hd2 references, that's the problem, there is no hd2. Just edit everything back one number in the case of hd? and if you see any /dev/sdb etc. Edit those back one letter to /dev/sda. After your first successful boot, immediately run

sudo update-grub

to fix the problem.

In a more complicated case, the UEFI Settings (BIOS) enumeration of the disks is different than what the running system sees. There you will need to figure out which disk number is really the one you want. Edit as above, but the update-grub will no longer be a permanent fix, you will need to edit after each kernel update.

It might be better to run boot-repair for information only, and post the output over in the forums. these UEFI problems frequently take more back and forth interaction than this question and answer site is set up for.

For UEFI machines (with a black screen grub (grub-efi) without any function key options, like the older grub-pc, edit the grub menu and add the below options on the "linux" line, then boot with F10 or ctrl-X.

Options for Video problems:

nomodeset
acpi=0
acpi_osi=linux
acpi_backlight=vendor
noalpic
i915.i915_enable_rc6=1
video=1280x1024-24@60
video=VGA-1:1280x1024-24@60

To allow Nvidia hybrid machines to boot:

nouveau.blacklist=1
share|improve this answer
    
Omg, installator works, but I can't bot ubuntu without installtion from usb stick. There is a problem with video. I did choose "lowest resolution for one session" and now thescreen is black. –  Sergey Feb 9 at 5:09
    
Even "console booting" menu option is not working. I select it, press click and see the black window. –  Sergey Feb 9 at 5:36
    
Ok, I got it. The problem is that ubuntu is not starting from USB stick even in console mode. It doesn't handle my "modern" videocard. Ok, so I'll try to defeat it. Would inform if success. –  Sergey Feb 10 at 12:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.