Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First, please do not mark this as duplicate. I have spent two days going through this website trying different things suggested.

I have 13.10 and using a Dell Inspiron Mini 1018 that has the following graphics:

sangie@Sangie-Netbook:/tmp$ sudo lshw -c video
  *-display:0 UNCLAIMED   
       description: VGA compatible controller
       product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list
       configuration: latency=0
       resources: memory:f0200000-f027ffff ioport:18d0(size=8) memory:d0000000-dfffffff memory:f0000000-f00fffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:f0280000-f02fffff

I have my drive encrypted, if that matters, and after I unlock it and the system starts to boot, I see a black screen but the backlight is on and adjustments to brightness doesn't help. Please note that I have auto-login enabled so login screens never come up. I've tried booting to older kernels and even tried 3.9 with no help. The only way I can boot is to use nomodeset or recovery mode, but then I'm stuck at 800 x 600 resolution with no way to change it.

My system has been working fine for months and I'm pretty sure I updated the base right before this happened. The full resolution is 1366 x 600 (I believe) so 800 x 600 makes everything stretched. Any help with this would be greatly appreciated.

Other things I've tried:

  • Using Intel's driver installer and running that and letting it install it's own drivers.. issue persisted.

  • Running system update again to the point where there's no more updates available.

  • Trying to boot to previous kernels in Grub
  • sudo apt-get update
share|improve this question

1 Answer 1

Maybe try the following first to update your intel driver:

sudo add-apt-repository ppa:glasen/intel-driver
sudo apt-get update
sudo apt-get install xserver-xorg-video-intel

This may also be down to certain chipsets needing KMS in order to run X and a desktop environment such as GNOME, KDE, Xfce, LXDE, etc. KMS is supported by Intel chipsets that use the i915 DRM driver.

  1. Dont use nomodeset or modeset=0, as it throws off KMS and you wont be able to do anything.
  2. sudo nano /etc/initramfs-tools/modules and add in the i915 and intel_agp drivers, save, and rebuild by running update-initramfs -u
share|improve this answer
    
Thank you for the quick reply. Unfortunately, none of this worked. I tried doing the intel-driver update as you listed and rebooted with no modifiers and I got teh black screen. I then went into recover mode and edited the file to look like this: '# raid1 # sd_mod i915 intel_agp' And then I tried sudo update-initramfs -u and rebooted and same thing :< Any further suggestions would be great. –  Redwolf Feb 9 at 18:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.