Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Bought a new Asus ux302LG and trying hard to install linux on it. The laptop has 3 screen options in hardware (HDMI,MiniDisplayPort, and build in laptop screen) The to external ports works, but the laptop screen does not work. Ubuntu doenst recognize the Nvidia 730M, but if I do a lspci i get the following:

    00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:04.0 Signal processing controller: Intel Corporation Device 0a03 (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.1 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 2 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 5 (rev e4)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
00:1f.6 Signal processing controller: Intel Corporation Lynx Point-LP Thermal (rev 04)
02:00.0 Unassigned class [ff00]: Device 1aea:6601
03:00.0 Network controller: Intel Corporation Wireless 7260 (rev 6b)
04:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)

What can I do to make the the graphic card avaliable? I think it will solve the screen not showing anything, even in cli mode (F1)

Edit: Have tried the following without result: Installing the driver downloaded from Nvidia: result-> no working screens at all. Webupd8 : result -> no working screens either.

share|improve this question

2 Answers 2

I have bought the same laptop ( Asus Zenbok ux302LG with nvidia secondary board).

It has been a nightmare but finally I have the nvidia board working under Ubuntu, while still keeping Windows alive in a dual boot mode.

This is what I did:

1 Enable BIOS->CSM (comptability module)

In Windows, shrink any partition you prefer and make free space and/or prepare a partition for ubuntu.

2 Boot with a Ubuntu 14.04 Live usb pen drive. Select the Install Ubuntu line and press E to edit boot options, and add the "nomodeset" kernel option. Then boot the installer

3 When asked for installation options, select Something Else and chose the free partition that you have created in step 1, and make sure you select to install the boot loader in that partition, not in the whole disk or other places.

Also stablish a wifi connection to do upgrades on the fly.

4 When finishing the installation, go to BIOS and select Ubuntu loader as the first boot option. Save changes and exit and you will appear in the ubuntu grub menu (you will also see that windows is still on offer, and it still works BTW). Edit the Ubuntu boot line and add the nomodeset option again (last time you need it)

5 ubuntu will boot and login in graphics mode, but still at low resolution and no access to nvidia board whatever you do (I tried both nvidia-prime and bumblebee a lot of times). Do not try any of them yet, just go to next step:

6 Install the 64bits kernel of the day (I used 3.16.0-994-generic ) and also its linux headers. I used the standard software installation tool for that. It is easy and you can find a lot of tutorials about it on google, so I will not bother with more details. This is a key step, as recent kernels seem to solve several critical problems with this laptop.

7 After installing the kernel then reboot (but do not add the nomodeset option anymore! ). Now it will login in a nice fullHD layout for the first time. You will also notice that the keyboard backlight is working fine. But no nvidia acceleration yet.

8 Now install Bumblebee, primus, and nvidia driver:

In the software installation application, enable the Universe and Multiverse repositories

Then:

sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-331

(for more details, I followed this link How to set up nVidia Optimus/Bumblebee in 14.04 )

9 Do a reboot after installing them. This is important.

10 Now you can Use primusrun to run your application. ( optirun does not work for me, but primusrun works perfectly in this laptop )

For example, type: primusrun firefox (it will show some warnings in the console, but it works)

A last tip: The loaders of many applications (the names that you use to call them in the command line or icon metadata ) are sometimes just a script that will call the application binary later inside the script. In these cases, primusrun will not work from the outside of the script. If you see that the loader is is a text file (script) you will have to edit that file and add primusrun to the line where the actual binary application is called. This was confusing me initially.

Thats all, good luck and hope it helps.

Javier

share|improve this answer

Have you installed the nvidia restricted drivers? The default driver for nvidia cards doesn't support 3d nor some of the newer cards/chipsets.

see this intruction

You can also use the nvidia supplied closed-source drivers.

which are available from them at this link

share|improve this answer
    
The problem is that it is not recognized by the system as a graphic card, so I cannot do what the instruction wants me to do. The driver is as I can see most for dedicated graphics, and need some more for Optimus, but will give it a try. –  Sofus Albertsen Feb 9 at 10:38
    
The drivers only resulted in black screen with an X cursor, and nothing on the laptop screen –  Sofus Albertsen Feb 9 at 11:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.