Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu installed as the sole OS on a T420. Before this I had installed the #! distro (and Xubuntu before that) and wireless worked seamlessly on either. My home hotspot shows up but when I click on it tries for a while before disconnecting.

Before going into the problem further, I wanted to double check that I entered the wifi password for my home network correctly. I went to Edit Connections >> Wi-Fi Security and changed the key, but it is still not able to connect. So I think the password is definitely correct. I don't understand why it can't connect now.

share|improve this question
1  
Could you please try to remove the current access-point by changing to the directory. Using a terminal cd /etc/NetworkManager/system-connections & ls to list down all saved AP's.. Once you noted your AP, issue sudo rm you_access_point_name to remove & restart your network manager with sudo service network-manager restart.. see whether it helps! :) –  AzkerM Feb 8 at 7:04
    
@AzkerMohamed it did indeed :) Thanks! Could you post this as an answer? –  yayu Feb 8 at 7:09
    
I'm glad it helped you. I've posted it as an answer. :) –  AzkerM Feb 8 at 7:29

1 Answer 1

up vote 2 down vote accepted

Could you please try to remove the current access-point by changing to the directory. Using a terminal

  • Open a terminal (CTRL+ALT+T) & type below command in a sequence;
cd /etc/NetworkManager/system-connections      # locate all the stored network profiles
ls                                             # list down the network profiles
sudo rm you_access_point_name                  # removes the specified profile
  • Restart your network manager with;
sudo service network-manager restart
  • Try connecting to the WiFi once restarted.

Hope it helps!

share|improve this answer
    
recently on two ubuntu installs the wifi network was no longer seen (possiblty caused by an update), following your steps and doing a restart fixed it –  Răzvan Panda Mar 1 at 17:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.