Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Currently my lock screen is what I am assuming is the default lock screen. the command: gnome-screensaver-command -l activates this screen.

I installed light-locker and want the system to use this instead, but when my system goes into suspend it still activates the gnome-screensaver's lock screen.

Also, the reason for wanting to switch is the gnome lock screen doesn't always allow me to "Switch User".

Thanks.

share|improve this question
    
That's funny.. it lets me switch users. –  Seth Feb 8 at 0:25
    
Supposedly light-locker-command -l should make it use light-locker instead of gnome-screensaver. If you want Ctrl+Alt+L to lock it you will have to change the keyboard shortcut. –  Seth Feb 8 at 0:27
    
I installed light-locker and can run light-locker-command -l, but gnome-screensaver is still being used. Interestingly enough, once light-locker was installed, the gnome-screensaver lock screen is allowing me to switch users again. At least for now. –  Jibbers Feb 8 at 5:25

1 Answer 1

up vote 0 down vote accepted

It turns out that this is handled in gsettings.

I used this command: gsettings set org.gnome.desktop.screensaver user-switch-enabled

After this I did a reboot and user switching worked again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.