Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently I upgraded to Ubuntu 11.04. The clock indicator on the panel is not following my regional settings format.

I edited locales and in all applications I have the right format of date and time except clock indicator on the panel. Tried dconfig editor but keys for clock applet cannot be changed. Tried to purge indicator and reinstall it - still the same. Is there any way that

I could change formatting of datetime indicator?

  • Here is format I'm using system wide: %A, %d %B %Y, %I:%M:%S
  • Here is format of datetime-indicator that pops up: %a%B%d %H:%M:%S
share|improve this question

1 Answer 1

up vote 6 down vote accepted

Try the following:

gsettings set com.canonical.indicator.datetime time-format "'custom'"
gsettings set com.canonical.indicator.datetime custom-time-format "'%A, %d %B %Y, %I:%M:%S'"

That seems to do the trick for me. You should be able to do the same using dconf-editor.

In dconf editor, it'd be something like this:

enter image description here

share|improve this answer
    
Yes I found this sollution before but that is not working for me. There is no such schema as com.cannonical.indicator.datetime in my system for some reason. The only thing about time formatting I found is in schemas.apps.clock_applet.prefs. But when I try to change format to custom and formatting to what I want the message pops up: "Keys cannot be modified at this time". When I created new key that can be edited then I got warning: "This key has no schema". And now I'm stuck. –  Wojciech May 11 '11 at 12:37
    
Finally I got it to work. This is how it worked in my case. First alt+F2 and gksudo dconf-editor (before I was starting gconf-editor). Nothing showed up o the screen but I beleive it started in background. Then I opened terminal and used commands that James posted above (thanks). And voila I got my clock indicator where I wanted :-))) –  Wojciech May 11 '11 at 22:19
    
You shouldn't have needed to use sudo. The preferences are per-user. –  James Henstridge May 12 '11 at 0:12
    
For some reason without sudo it did not work. Later on I downloaded dconf-tools from repository. And now I can see all schemas and do not have to use sudo. Glitch??? Anyway thanks, it's working now. –  Wojciech May 12 '11 at 11:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.