Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cannot get internet working at my work place, may be because of proxy. At home internet works perfectly fine. Virtual Box is using NAT for network connection. I had also tried changing the connection to Bridged and didn't work either. I have seen a lot of posts on this and none of them have solved my issue. Unless this one works I cannot connect to CVS from Eclipse.

eth1      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx  
      inet addr:  Bcast:  Mask:
      inet6 addr: xxxx::a00:27ff:fe4a:f961/64 Scope:Link
      RX packets:372126 errors:3 dropped:0 overruns:0 frame:0
      TX packets:173506 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:446759931 (446.7 MB)  TX bytes:10066402 (10.0 MB)
      Interrupt:10 Base address:0xd020 

 lo        Link encap:Local Loopback  
      inet addr:  Mask:
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:710 errors:0 dropped:0 overruns:0 frame:0
      TX packets:710 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:66411 (66.4 KB)  TX bytes:66411 (66.4 KB)

This is what I have in /etc/network/interfaces/

auto lo
iface lo inet loopback

I tried appending below settings, didn't work for me

auto eth1
iface eth1 inet loopback

Can someone help me how to get this working. Virtual Box with Windows 7 Guest working perfectly fine, but not Ubuntu. This problem is it fixed in later versions of Ubuntu, so that I can update it or any suggestions on fixing this

share|improve this question

As far as I know it will only work with bridged mode. Also you might have to set the proxy of Ubuntu too.

What is the ifconfig output when you use bridged mode?

To set a proxy try:

export http_proxy=ip.or.hostname:port

share|improve this answer
Network is always trying to connect, it doesn't connect in bridge mode. Ubuntu doesn't even start quickly, I get Waiting up to 60 more seconds for network configuration. /etc/network/interfaces doesn't even show the eth1 config. It just shows lo – user14010 Feb 7 '14 at 13:01

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.