Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use Ubuntu 12.04 on a 64-bit computer. When I try to install anything, the following happens:

$ sudo apt-get install ia32-libs
Leyendo lista de paquetes.0.. Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 ia32-libs : Depende: ia32-libs-multiarch
E: No se pudieron corregir los problemas, usted ha retenido paquetes rotos.

This does not depend on the package I try to install, there's always an unmet dependency.

I have tried everything related to apt-get:

$ sudo apt-get install -f
$ sudo apt-get update
$ sudo apt-get upgrade
$ sudo apt-get autoremove
$ sudo apt-get clean
$ sudo apt-get autoclean

and every other "solution" I found on several forums. I also tried removing two PPA repositories from the list.

Synaptic says I don't have broken packages but when I try to install something, it finds unmet dependencies.

Finally, I am not allowed to make a distribution upgrade for work reasons.

What is going on with the packages? Can you help me?

If you need any other information, let me know.

Thanks in advance.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.