Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a netbook I use for school, and sometimes it doesn't suspend properly when I close the lid, causing it to get hot inside it's case. I opened it today and it was at 150F. It worked, but I didn't like the smell (probably just the superglue on the bezel).

I was wondering if there's a way I can lower what the critical temperature is so it shuts down at around 140. Is there a way to do this? Does it have to be done in the BIOS? (something I read in another thread). It's an HP1103

share|improve this question
5  
I think that more important is that you should fix the fact that it doesn't suspend when you close the lid. –  Braiam Feb 6 at 17:10
    
The CPU is rated to operate at temperatures well above that. –  psusi Feb 6 at 18:42
    
There are three different HP1103. Which of the three is it? –  blade19899 Feb 6 at 20:53
1  
I had to go convert that to Celsius in order to fully understand the question (it was 66 C). Perhaps you should change whatever is displaying the temperature, as the thermal specifications for hardware are always given in Celsius. –  Michael Hampton Feb 6 at 22:56
    
140 Fahrenheit grades are not that hot in the computer terms, what you should instead fix is the system not suspending when you close the lid. –  Braiam Feb 7 at 4:35

3 Answers 3

You can try Computer Temp at Computer Temperature Monitor

Computer Temperature Monitor is a little applet for the GNOME desktop that shows the temperature of your computer CPU and disks on screen.

It also allows you to log temperatures to a file. You can set alarms to notify you when a tempertature is reached. Several monitors can be added to the panel to monitor different sensors. It is designed to look like CPU Frequency Gnome applet, so they match each other on panel.

Other way around it is to cool your CPU temperature frequency throttling:

Sepero Hacker: Linux: Cool your CPU temperature with frequency throttling

share|improve this answer
    
Thanks. I have the applet, but I won't hear the alarm from my bag, and it isn't a problem when it's outside the bag. I want it the computer to take action by itself at around 140. For context, normal operating temperature is about 95, up to 100. –  user227143 Feb 6 at 16:48
    
Look at the temperature frequency throttling –  LnxSlck Feb 6 at 17:06

The better option is to follow the advice in the comment (try to see what has failed when you closed the lid).

As a workaround, or a safety net, you can use a script running in background, something like this one, which depend on the package lm-sensors being installed:

#! /bin/bash

while true; do
    t=$(sensors | grep temp1 | awk '{print $2}' | sed 's/\..*$//')
    if (( $t > 95 )); then   # max temp in whichever units your sensors outputs
        echo High temp $t
            #sudo /usr/sbin/pm-suspend   # uncomment after testing.  
    fi
    sleep 60
done

You have to change temp1 to something relevant for you (look at the output of the command sensors in a terminal). In my case it is:

(0)asus-romano:/etc% sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +61.0°C  (crit = +98.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +46.0°C  (crit = +100.0°C)

...and I want to check temp1. You have to put a string that is able to select only the line you like, so that the pipe in $(..) outputs only the temperature numner. You can test it by hand in the terminal:

(0)asus-romano:/etc% sensors | grep temp1 | awk '{print $2}' | sed 's/\..*$//'
+61

To being able to do the poweroff with sudo without being asked for a password, you can add a file to the directory /etc/sudoers.d:

(1)asus-romano:/etc% sudo cat /etc/sudoers.d/power-off
romano ALL=NOPASSWD: /usr/sbin/pm-suspend
romano ALL=NOPASSWD: /sbin/poweroff

(adapt with your user, obviously --- note that the file content is just the two last lines. The name of the file is irrelevant, see more here) --- now your user will have the power to use this two commands (with sudo) without being asked for a password.

share|improve this answer

Another solution may be to "hibernate" instead of "sleep". With "hibernate" the netbook really shuts down, so there's no way it will heat up. And it's fast too, though not that fast.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.