Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

Software Center will not start for me. I have ran the following commands and none of them have worked.

$ sudo apt-get update
$ sudo apt-get upgrade

$ sudo apt-get install software-center

sudo apt-get install --reinstall python2.7

sudo apt-get install --reinstall ubuntu-desktop

All of this to no avail. Here is the read out when I run software-center directly from terminal.

ryan@ryan-Satellite-M645:~$ software-center
2014-02-06 10:49:50,435 - - INFO - setting up proxy 'None'
2014-02-06 10:49:50,488 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/dbus/', 410, '_introspect_error_handler')'
2014-02-06 10:49:50,488 - dbus.proxies - ERROR - Introspect error on com.ubuntu.sso:/com/ubuntu/sso/credentials: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1
Traceback (most recent call last):
  File "/usr/bin/software-center", line 130, in 
    app = SoftwareCenterAppGtk3(options, args)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/", line 338, in __init__
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/", line 66, in __init__
    self.oauth_token = helper.find_oauth_token_sync()
  File "/usr/share/software-center/softwarecenter/backend/", line 141, in find_oauth_token_sync
  File "/usr/share/software-center/softwarecenter/backend/login_impl/", line 74, in find_credentials
    self.proxy.find_credentials(self.appname, self._get_params())
  File "/usr/lib/python2.7/dist-packages/dbus/", line 70, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/python2.7/dist-packages/dbus/", line 145, in __call__
  File "/usr/lib/python2.7/dist-packages/dbus/", line 651, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/lib/ubuntu-sso-client/ubuntu-sso-login exited with status 1

This happened after I installed setup-tools and I tried to install wireshark from the software center.

share|improve this question

marked as duplicate by dobey, guntbert, karel, Braiam, mikewhatever Feb 7 '14 at 6:24

This question was marked as an exact duplicate of an existing question.

Press CTRL+ALT+T simultaneously to enter terminal.

To uninstall Software Center:

sudo apt-get remove software-center
sudo apt-get update
sudo apt-get install software-center

hope this'll help

share|improve this answer
Thanks for the post, but did not work for me. The solve on the linked page did it for me. – Hanks98 Feb 12 '14 at 16:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.