Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I just got rid of Windows 7 starter and installed Xubuntu 12.04 but the network manager after trying to enable wireless says

wireless is disabled by hardware switch

I have googled around and found no solution.

rfkill list says

2: phy0: Wireless LAN Hard blocked: yes

and rfkill unblock all doesn't do anything.

I am also 100% sure my switch on the machine is turned on and the Fn+F5 combination doesn't fix it either.

I have tried BIOS reset with no luck and rearranging the boot order with also no luck. The only way I can connect to the Internet on this machine is through USB smartphone WiFi, I think the cable port is broken.

I have also tried with no luck so far:

sudo rfkill unblock all
rmmod ath5k && modprobe ath5k
rm /dev/rfkill    
sudo iwconfig wlan0 txpower auto

I'm kind of stuck now and don't know what else to do, my last idea is to reinstall Windows 7 just to turn this WiFi back on but that's the last thing I'd want to do. Thanks.

share|improve this question
1  
Please edit your question to add the entirety of: rfkill list all –  chili555 Feb 6 at 12:47
add comment

1 Answer 1

Oh no. I've been there. There's only one solution. You have to either install windows and turn the hardware switch back on. Or the following, and this is what I did. You have to open your netbook and take out the battery to do a CMOS reset. Here's the tutorial I followed: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/577114/comments/31

It was also discussed here: http://www.linlap.com/lenovo_ideapad_s10-3

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.