Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.04 and my internal mic (next to the webcam) is not being detected. I tried recording the sound with sound recorder and also tried with skype but it failed.

Recording works when I use an external mic.

I have tried playing around with alsamixer but it did not help. Is there any way to fix this?

share|improve this question
    
it doesn't show internal microphone in connector: in my case shows analog input –  flamingburner Oct 16 '11 at 19:15
add comment

3 Answers

using pavucontrol (installed as explained in a differ answer) in the "configuration" tab the selected profile for "internal audio" was "Analog Stereo Output". I changed it to "Analog Stereo Duplex" and the problem was solved

share|improve this answer
add comment

Try running alsa-mixer in terminal and look for internal mic in that program (it uses curses-like ui, left-right to change channel, space to turn on/off, up and down to adjust volume). I don't have that particular Dell, but it helped on a few laptops I had.

share|improve this answer
add comment

I would strongly recommend that you install PAVU sound mixer
Install from Software Center:

Install via the software center

Or install it in a terminal:

sudo apt-get install pavucontrol

Then hit alt + f2 and type pavucontrol and up should come the launcher for PAVU which you can use to make sure your sound control and inputs are all correct.

Under input you will see probably see the internal mic named and either muted or turned right down. See if that will help if you try to change the levels. You should see it react to external noises ( ie you!) with the monitor responding to you coughing or tapping the keyboard.

You can of course use gnome-volume-control as well which is what you will find if you click the volume bar at the top of your panel and select 'sound preferences' enter image description here

share|improve this answer
    
Does pavucontrol work better than gnome-volume-control (which can be started by clicking on the loudspeaker icon in the panel)? Both look a bit different, but I couldn't find a big difference on the first glance. –  elmicha May 10 '11 at 21:01
1  
Not better, but just for me a little easier. Certainly gnome-volume-control is a little better now than it was but I still find pavu a little better looking perhaps. Will stick a piccie up now with the pair of them above –  andybleaden May 11 '11 at 6:17
    
hi andybleaden, i tried using that PAVU but it was of no help. i see no fluctuations in the audio level. it shows no response to my voice. i tried the sound preferences also but it did not work as well. let me know if u need some screen shots and report which may be helpful in resolving this.. –  Prashan May 29 '11 at 16:11
    
Oh eck...sorry it has not worked for you.Yes if you repeat the screen shots I have put up that would be a help then we could see what the difference there is. Also could you have copy and upload your screen in a terminal from these two commands sudo alsamixer and then lspci –  andybleaden May 30 '11 at 6:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.