Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a few problems with my recently purchased notebook lenovo G510 and as a beginner I do not know how to solve those problems.

to the point: my AMD Radeon graphic is not worknig at all and the brightness buttons do not function as well - there are some tutorial to help but I was unsuccessful. Thank you guys for your help.

BOOT_IMAGE=/boot/vmlinuz-3.2.0-58-generic root=UUID=ad62cbb7-c145-417a-9b3f-bb7250fbb0a9 ro splash quiet vt.handoff=7

00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
    Subsystem: Lenovo Device 3801
share|improve this question

1 Answer 1

I believe that the laptop uses Hybrid Graphics (AMD + Intel). Hybrid Graphics are problematic in Linux right now, there's nothing that will work 100% for everyone. I recommend disabling the discrete AMD GPU so that it won't chew up your battery life.

To resolve the brightness button issue you're having, follow these steps:

  1. Open up a terminal (Ctrl + Alt + T)
  2. Type in the command:

    gksudo gedit /etc/default/grub
    
  3. In that file you will find a line like this GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Append the following after splash acpi_backlight=vendor so the line looks like:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    

    And save the file and exit gedit.

  4. Now in the terminal execute the following command:

    sudo update-grub
    

    Now reboot and your brightness buttons should work.

You probably have the discrete card running and chewing up your battery. If so, you can disable it via vgaswitcheroo. Type this command in a terminal:

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

To make the changes to persist after reboot you can put this command in your /etc/rc.local so that it executes at every bootup, in a terminal execute:

gksudo /etc/rc.local

At the end of the file before the exit 0 line, paste the command echo OFF > /sys/kernel/debug/vgaswitcheroo/switch, save and you're good to go now the discrete GPU will be disabled at boot.

For more information see HybridGraphics

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.