Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed the current nvidia restricted driver and rebooted my machine and now I get a black or blank screen.

How can I fix this?

share|improve this question
    
(Those going for the bounty on this question, there's no need to redo all the optimus options, just add those existing answers as links in an all encompassing answer, cross-link as much as you can!) –  Jorge Castro Jul 12 '12 at 0:48
1  
A lot of the answers will fail using "sudo apt-get install nvidia-common" because of this bug: bugs.launchpad.net/ubuntu/+source/nvidia-common/+bug/981874 –  keepitsimpleengineer Oct 17 '12 at 19:13

16 Answers 16

The biggest trouble I had was getting a Macbook Pro to install the Nvidia drivers!!!

The solution is to change the Master Boot Partition to REMOVE EFI and go with Legacy MBP.

This is discussed on a few webpages but is not so easy to follow.

https://bbs.archlinux.org/viewtopic.php?id=162289

Using this idea, I booted from a Live CD and then using Gparted removed the EFI boot partition, changed it from EFI to FAT32 and then using Boot-Repair rebuilt it as a legacy boot using the main Partition with 13.04 64 bit installed

https://help.ubuntu.com/community/Boot-Repair

---WARNING BACK UP YOUR DATA FIRST. YOU COULD SCREW UP EVERYTHING ON YOUR HDD ---

Insert Live CD - Boot up as try Ubuntu Run Gparted - Change EFI boot partition from EFI to FAT32.

open a new Terminal, then type:

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

  • Press Enter.

  • Then type:

sudo apt-get install -y boot-repair && (boot-repair &)

In boot repair select ADVANCED OPTIONS

Uncheck Use the Standard EFI File under main options Uncheck Separate /boot/efi partition under GRUB LOCATION

follow prompts on how to use the legacy Boot loader that Boot Repair will give you.

Now install and load the NVidia drivers as many post

I used the method 2 on this page http://www.dedoimedo.com/computers/ubuntu-ringtail-nvidia.html

I was working on this for probably 18 hours and tried EVERY option available. I mean every possibly way to install these friggin drivers, and this was the only solution that works for the Macbook Pro 7.1 Running 13.04 with Nvidia_current (nvidia_304)

share|improve this answer

Just install clear ubuntu (no updates, no software) connect with internet, download your driver and install and reboot! Worked for me! Thanks for my neighbour!!! (that was his idea)

share|improve this answer
4  
Using Ubuntu without running any updates is really not recommended. Bugs are being fixed and security wise it is also a bad idea. –  gertvdijk Jul 2 '13 at 8:33
    
@gertvdijk Perhaps the intent of this post is to recommend installing Ubuntu without updates, installing the driver, and then installing updates (but not until after the driver is installed). If so, I'm not sure why that would work better, but it would be acceptably safe. –  Eliah Kagan Jul 2 '13 at 14:04
    
@EliahKagan Could be, but if so, then that sounds really unlikely to me. Nvidia's driver is rebuilt for every new kernel. –  gertvdijk Jul 2 '13 at 15:26
  1. Remove any drivers that may be causing the issue,
  2. open the terminal and type ( open it from the dash, using the ubuntu icon on the left corner)

    sudo apt-get --purge remove nvidia
    

    or

    sudo apt-get --purge remove nvidia-current
    

    (Depending on which one you have installed) or deactivate them from the restricted driver settings.

  3. reboot.

  4. then on a terminal type this:

    sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current nvidia-settings
    
  5. reboot.

share|improve this answer
2  
This worked for me, but left me with 640x480 equivalent problem to askubuntu.com/questions/201123/…. Also, use Shift/Esc during boot to enter linux equivalent of 'safe mode' so that you can execute these commands –  Alex Oct 22 '12 at 0:29
    
Damn rep won't let me edit my own comment - just wanted to add that the solution proposed for the 640x480 problem in the question referenced above works fine, so don't let that hold you back. –  Alex Oct 22 '12 at 0:46
1  
If my computer starts up with a blank screen, how can I open a terminal to type those commands? The screen is blank! –  Stefan Lasiewski Nov 11 '12 at 4:35
    
@StefanLasiewski askubuntu.com/questions/162075/… –  Uri Herrera Nov 11 '12 at 7:42

I was getting a black screen when booting. I have a NVIDIA 6200 graphics card. Renaming xorg.config and rebooting worked for me. The xorg.config file created by nvidia-xconfig: version 304.51 (buildmeister@swio-display-x86-rhel47-06.nvidia.com) was causing the problem.

share|improve this answer

In my case it was a problem with the monitor giving my Nvidia GPU a bad EDID

To debug your error, you can add this line to the screen section in the the /etc/X11/xorg.conf file

Option         "ModeDebug" "true"

Now check your /var/log/Xorg.0.log file.

If you find an error like this:

NVIDIA(0): Unable to get display device DFP-0's EDID; cannot compute DPI

Then you can resolve it by adding this line to the device section

Option         "IgnoreEDIDChecksum" "DFP"
share|improve this answer

This happened to me when running an AMD cpu: Learned it was an IOMMU/AMD -v Bug = Incompatible with Nvidia. Disabling Virtualization bios settings fixed this.

share|improve this answer

Press Alt+Ctrl+F1 to get to tty1 (terminal), then run this:

sudo apt-get --purge remove nvidia*

That will remove any nvidia driver packages. If that still doesn't work, try this also:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.mybak

That will remove a corrupted xorg configuration file if it exists. You will need to reboot after finishing these commands. (Ctrl+Alt+del)

PS. If you have an nvidia optimus card, do not install the x-swat or any other nvidia drivers. The best working drivers for nvidia optimus cards come from the bumblebee project.

share|improve this answer

Remove everything to do with the Nvidia proprietary drivers.

  1. sudo nvidia-settings --uninstall
  2. sudo apt-get remove --purge nvidia*

Start from scratch.

  1. sudo apt-get remove --purge xserver-xorg-video-nouveau xserver-xorg-video-nv

Reinstall all the things!

  1. sudo apt-get install nvidia-common
  2. sudo apt-get install xserver-xorg-video-nouveau
  3. sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core

Reconfigure the X server.

  1. sudo dpkg-reconfigure xserver-xorg

Source: Ubuntu Wiki

share|improve this answer
1  
Finally, that fixed it (omitted "Start from scratch" stage - didn't fancy uninstalling xserver!) but did all the other steps and it works a treat. Many thanks! –  RobinLovelace Apr 10 '13 at 9:56
3  
That wiki is outdated. the nvidia-settings --uninstall doesn't work, for example. –  NoBugs Jan 11 at 22:35
    
@NoBugs: yes, but following the steps still fixes the graphics on 14.04 after reboot –  J.F. Sebastian Sep 9 at 20:22

I agree with Wolf above. Have you tried the open source drivers? And how did you install the restricted driver? I just installed a new Nvidia card similar to yours and installed the restricted driver by following this tutorial and everything worked out great. This page shows to methods, one using a GUI and the other via terminal but with only three needed commands. Install Proprietary/Restricted Drivers

share|improve this answer

Maybe Ubuntu IT'S working but using another card output. For me, my nVidia GeForce 7300 has 2 output, a VGA and a DVI. It seems like the default output when you install the drivers is to DVI but I don't have a DVI monitor so I managed to get to Recovery Mode (available in GRUB when you boot) and type this:

nvidia-xconfig --twinview --twinview-orientation="Clone"

Now Reboot.

This command directs the same graphics to both outputs. From there on, you can keep experimenting with this nVidia utility until you get what you want. For more information type:

nvidia-xconfig -A | less

Hope that helps.

share|improve this answer

I got a blank screen as well, but this was on a laptop with and nVidia optimus card 4200m. Optimus does not seem to be supported well on Ubuntu. I had to disable optimus from the bios and then reinstall the nividia driver. More here if you want to read http://developerslog.org/?p=69

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Oyibo Nov 11 '12 at 8:49

Try acpi=off. That solved my booting into blank screen issue for Ubuntu 11.10.

share|improve this answer
    
The original question was an old one. The reason this probably wasn't suggested at the time is that the problem occurred only after the proprietary driver was installed. A better answer might be to revert to the last known working driver, then try alternate nvidia drivers that have become available. –  fabricator4 Nov 11 '12 at 0:08

Try in /etc/default/grub:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_GFXMODE=1680x1050x32

Replace "1680x1050x32| with your native resolution (to get it run vbeinfo in the grub console when booting).

Then in /etc/grub.d/00_header:

set gfxmode=${GRUB_GFXMODE} <-- FIND THIS LINE
set gfxpayload=keep <-- ADD THIS LINE DIRECTLY BENEATH

Update grub:

sudo update-grub

Might work...

share|improve this answer
    
Can you explain what some of these options do? What does gfxpayload do, for example? –  Stefan Lasiewski Nov 11 '12 at 4:37

Instead of using nvidia-current you should really try to use an older nvidia driver e.g. the 173.xx. This solved the problem for me. Just start jockey-gtk and chose the 173.xx driver. Than reboot your system.

share|improve this answer

Does that thread on Ubuntu Forums help you?

In short, it seems that the linux-header packages for some of the kernels (notably the PAE kernels) are not properly installed, and the nvidia driver compilation fails silently when installing the nvidia packages.

share|improve this answer
    
Thx for your post. But see edit 5! What can i do? –  LaMinifalda May 13 '11 at 21:24

Regarding the topic title: What is the current restricted nvidia driver version used in Ubuntu natty?

You can find anything about releases, versions, bugs, requested features on Launchpad. To understand what it is about you can take their tour.

The question about the latest version of the nVidia driver can be found on “nvidia-current” binary package in Ubuntu Natty i386. So as of 2011-04-20 the latest version is 270.41.06-0ubuntu1. But that is not necessarily the recommended one. The latest one for me always seems buggy (like 'tearing' etc).

share|improve this answer
    
Thanks for your answer! –  LaMinifalda May 10 '11 at 16:13

protected by Community Dec 11 '13 at 1:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.