Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

There have been a number of users reporting this starting as early as google chrome 11.0.696 on Lucid Lynx. I am seeing it currently on chrome version 16.0.912.75 (Official Build 116452) on Oneiric Ocelot.

Despite having the cookies setting set to allow all cookies, and the "clear cookies on shutdown" option unchecked, All cookies (and sessions that rely on cookies to be persistent) are cleared. This makes using the browser very tedious if you (like me) shut down the browser at the end of the day.

I am currently looking into the 'bug' status of this; However if there is a workaround I can apply in the mean time that would be great! Or if anyone has any further information as to the cause of this bug (I am aware not all users are victim to this behaviour).

To better explain the issue I have created a small video (don't mind the slow internet connection) which can be seen here

share|improve this question
    
This might be obvious, but I thought I'd better rule it out anyway: Are you sure that the sites you're logging in to are using persistent cookies, not session cookies? –  Scott Severance May 17 '11 at 5:40
    
@Scott Severance Yeah, I've tested on sites that I am in control of. –  Kzqai May 17 '11 at 15:13
    
I am also victim of this bug. I can also verify that sites i'm in control of using persistent cookies are not being remembered. Furthermore if you open the "Cookies and Other Data" page you will see the list of cookies is cleared between browser sessions. –  rlemon Jan 18 '12 at 15:37
    
@Tchalvak I don't know if you are still watching this Question, however I hope my solution helps you as well. –  rlemon Jan 19 '12 at 13:41
    
@Tchalvak how are you coming with this? Can one of the answers below be accepted now? –  rlemon Feb 27 '12 at 13:45

3 Answers 3

up vote 3 down vote accepted

The solution is to remove chrome, including it's cache and config directories. To do this type the following from the terminal.

sudo apt-get remove google-chrome-stable (beta, dev, ect) un-install chrome

rm -rf ~/.cache/google-chrome* ~/.config/google-chrome* remove the cache and config directories

this will also remove the rouge folder... ~/.config/google-chromed/ (not sure where this came from... but I had to remove it) I have a suspicion this is the culprit, however I cannot figure out where it came from or what it's purpose was.

then re-install chrome and you're set: sudo apt-get install google-chrome-stable

note:

It is highly recommended that you sync your browser with a google account, or at the very least you backup your preferences before you wipe away your browser like that.

share|improve this answer

Check if you have "Allow local data to be set" selected. To access the option, Preferences > Under the hood > Content settings > Cookies.

enter image description here

share|improve this answer
    
yes that is set. all applicable settings are set to allow this information to be saved. –  rlemon Jan 18 '12 at 22:38

I found that the Date modified of my Chrome Cookies file is a few months behind. So I presume that this SQLite3 database may be crashed or something.

I just removed the file ~/.config/google-chrome/Default/Cookies and restarted Chrome browser. This recreated the 'Cookies' file again and now the Google Chrome does keep cookies. Also make sure that answer by jokerdino is carried out.

share|improve this answer
    
My file was about 45 minutes in the future, but I had the same problem. Deleting the Cookies and Cookies-journal files and then restarting also fixed it for me. –  paulcm Aug 26 '12 at 15:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.