Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I opened Wine configuration page for the first time while music was playing in the background. Just when I opened the Audio tab, the sound stopped working and Wine alerted me about my audio driver. Now my PC has no sound!

What should I do to get back audio? I don't need audio in Wine.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Wine and pulseaudio have always had difficulties working together. If your not sure about the different sound systems available on Ubuntu/Linux, here's a very simplified overview (from my memory, so it may not be 100% correct).

  • OSS Older linux audio subsystem, essentially only allows audio output from one application at a time.
  • ALSA - Newer audio subsystem, allowed output of audio from multiple applications at the same time, however only allowed 1 master volume to control all application volumes (e.g. no turning down the music when you get a call on skype. You can have sound from both applications, but only at the same volume).
  • PulseAudio - Essentially an interface layer that sits on top of ALSA, allows multiple applications to have their own volumes and sound settings. This is the default on Ubuntu.

There are several other differences between each one, but that's all that really matters to the end user as far as I'm concerned. However Wine and PulseAudio are historically pretty buggy together, and I have a feeling that sound output will die when you run any Wine application (not just winecfg). You have a few options to prevent this, none of them ideal (ideally you wouldn't have to do anything!)

  1. Kill the pulseaudio subsystem before doing anything with Wine. Open system-monitor, go to the processes tab, highlight pulseaudio process and press "kill" (or something along those lines, I'm posting from work). Alternatively run this at the terminal: killall -9 pulseaudio Then open wine, do your thing and sound should work correctly. When your done, if you want pulseaudio back, press super+f2, type pulseaudio, and hit enter.

  2. Alternatively, you can follow the instructions in this blog post to configure wine to use the OSS subsystem.

share|improve this answer
    
thanks, complete answer. i used it. i solved the problem by temporrily change Hardware Profile in Sound Preferences. and +1 for the link to article. –  Alexar Sep 14 '10 at 17:30

To get sound back when Wine destroys it all, you only need to do:

killall -9 pulseaudio

The pulseaudio system will restart itself in a few seconds, there is no need to manually run it.

To avoid this situation I usually try and close apps that will make sound while Wine is running, in particular Firefox with Flash. I also set my IM status to away (where the client is configured to not make message sounds)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.