Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to deploy OpenStack Havana over Ubuntu Precise using juju.

This is what I do exactly:

  • Install Ubuntu server with maas following the official guide.
  • sudo maas createsuperuser
  • sudo apt-get install maas-dhcp maas-dns
  • sudo ufw disable
  • sudo apt-get install python-software-properties
  • sudo add-apt-repository cloud-archive:havana
  • sudo apt-get update && sudo apt-get install juju-core
  • sudo apt-get update && sudo apt-get dist-upgrade
  • sudo maas-import-pxe-file

At this point everything seems O.K. till I reboot the server. when I browse MAAS URL I get Internal Server Error "Apache/2.2.22 (Ubuntu) Server at 192.168.50.240 Port 80"

This is the last errors at apache2 log

http://pastebin.ubuntu.com/6877380/

I tried this for three times and I got the same error. Any clue what I did wrong?

Thank you

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

OK I repeated the same practice without "sudo apt-get dist-upgrade" and the error was gone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.