Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to get Ubuntu 11.04 to login automatically, but the login screen options don't seem to allow this.

There is no option to select my username, as this screenshot shows:

shot

Any ideas?

share|improve this question
    
What is the username you'd expect to show up? (any 'weird' characters in it?) I would file a bug on this if I was you. –  Rinzwind May 10 '11 at 7:15
add comment

4 Answers

up vote 1 down vote accepted

Judging by this bug, do you have your home partition encrypted with encryptfs? If so, that might be the reason. Then either do not use autologin or do not have encrypted $HOME, those two cannot go together (on requires password for decrypting the home directory, the other wants to avoid entering passwords)

share|improve this answer
    
That's exactly it, thanks. I had enabled home folder encryption on install. The encryption is more important to me, so I can live with it. –  Karthik May 11 '11 at 2:55
add comment

These settings are store inside /etc/gdm/custom.conf

[daemon]
AutomaticLoginEnable=true
AutomaticLogin={username}
TimedLoginEnable=true
TimedLogin=user
TimedLoginDelay=10

You can edit this from commandline by doing gksu gedit /etc/gdm/custom.conf. Change your name where it says {username}. See if that works.

share|improve this answer
add comment

Edit /etc/gdm/custom.conf with your favorite editor.

Add (or change) following line, to make it look like this:

[greeter]
Exclude=teamspeak, nobody (or any user you want)
share|improve this answer
add comment

Also, user accounts with ids below 1000 will not be listed in this box. See How do I hide a user from the login list? for more details.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.