Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Background:

I have an HTPC with a raid 5 array. This setup has been working for nearly 1 year without a single hiccup. Ubuntu 12.04lts is installed on a separate ssd within the HTPC.

I have a pc where I do my ripping, encoding, picture editing, etc. running windows 7. For the last year, my entire array was accessible to me via network shortcuts so I could copy over the network from windows machine to ubuntu machine where my media is located.

My media is safe and the raid array and xbmc functioning correctly.

While setting up this HTPC, I did save many of the websites I used to help me. It seems, though, I didn't save the samba ones...

Problems start:

For whatever reason, a few weeks ago, I uninstalled samba. I don't remember exactly what I was trying to do, but I seem to remember thinking I didn't need it anymore. Make a long story short, I reinstalled it, got my shares working again, although, not exactly as they worked before. Previous to my stupidity, when I would open the Ubuntu file explorer, my raid array ("raid 5 storage"or /storage) would show up as a folder (called "raid 5 storage") right next to the network. Since reinstalling samba, that no longer happens. This isn't a big deal, because I can still access my array via /storage. However, this tells me I did not configure something properly, or at least as it was before. Not a big deal, just slightly vexing.

Now I need help...

Today, I installed a program called boxcryptor on my windows machine to play around with it. It maps all cloud storage accounts to a single folder for encryption. It uses X:. X: happened to be my movies share. It caused some weird interactions. After installation and restarting, none of my shares work. After uninstallation and restarting, none of my shares work. Ubuntu machine is gone from the network.

I have removed samba, reinstalled samba, stopped, started, reconfigured, poured over the .conf file. I'm stumped (it's not hard to do...).

I absolutely need (want?) samba to work in the way that it previously worked. I have seen countless google search results needed to change this setting or that on the windows machine that I feel have nothing to do with this problem.

From windows, I can't even see Ubuntu in my windows workgroup anymore. From Ubuntu, I can see the workgroup, but can't access it. I am 90% certain all of these problems are the result of wrong settings in samba. I just can't wrap my head around it at the moment.

Thanks to anyone willing to assist.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.