Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

The max I can set my resolution currently is 1024x768, but my laptop's native resolution is 1920x1080. I've always been able to set it to 1920x1080 without issue, but since I broke my video driver (I installed 'nvidia-current' which broke my display, see this thread) I haven't been able to get above the aforementioned 1024x768.

I've tried the instructions from this thread and this wiki but haven't made any progress.

Video Card:

travis@travis-ThinkPad-W510:~$ lscpi |grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GT216GLM [Quadro FX 880M] (rev a2)

Output for 'xrandr'

travis@travis-ThinkPad-W510:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
    1024x768       61.0*
    800x600        61.0  
    848x480         0.0  
    640x480        60.0  

Any suggestions?

Method used for trying to create '--newmode'

travis@travis-ThinkPad-W510:~$ cvt 1920 1080
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync     +vsync
travis@travis-ThinkPad-W510:~$ xrandr --newmode "1920x1080_60.00"  173.00  1920 2048     2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
share|improve this question
I've just asked a similar question on Unix & Linux (which might get migrated here). But I'm already scared of what answer I might get - your question looks much more complex than my current level of competence could handle. –  FumbleFingers Feb 4 '14 at 18:06

2 Answers 2

Latest NVIDIA GPUs, especially if designed to gaming (like my GTX 750), aren't supported by kernel.

You have to add an external ppa, install the graphic driver and reboot, so type in terminal:

sudo add-apt-repository ppa:mamarley/nvidia -y
sudo apt-get update
sudo apt-get install nvidia-346 nvidia-346-uvm && sudo reboot

The maximum resolution will be automatically used since login screen.

PS I don't reccomend you to install Nvidia driver from the Additional Driver dialog (despite it should be easier), as you can choose only an older version (340.xx), the 346.xx one is not mentioned.

share|improve this answer

You have probably removed the proprietary driver and your system is using generic VESA driver. Open System Settings → Software Sources, tab Additional Drivers and install the proprietary driver.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.